cancel
Showing results for 
Search instead for 
Did you mean: 

USB 2.0 devices no longer picked up in 3.0 hubs

Arkhen
Level 7
Windows 10, version 2004 (19041.508)

Motherboard: Asus Rampage V Extreme (latest BIOS)

On a fresh Windows 10 installation, fully updated, I'm completely unable to use my USB 2.0 devices in my 3.0 slots.
I've installed all the latest drivers on the official Asus page for my motherboard, but I still have this error in my Device Manager, and it still doesn't work.

- https://www.asus.com/Motherboards/RAMPAGE_V_EXTREME/HelpDesk_Download/

This system has worked fine for years, but suddenly I have these issues, and I suspect it's software related.

Any help is much appreciated!

86477
207 Views
1 REPLY 1

PipJones
Level 8
I think the Asus drivers are quite old now. Try getting the latest intel ones?

I'm still using my RVE and did a fresh W10 install recently. I have updated to the latest 20H2 build too. I am not using any drivers downloaded from the asus website. I appreciate that it doesn't help your situation, but, it should demonstrate you don't need the asus drivers?

The only USB2.0 devices that I'm using are mouse and keyboard, they are working. Ports closest to the PS2 port.

This is a great USB debug tool, might give you a few more clues as to what is going on?

https://www.nirsoft.net/utils/usb_devices_view.html