cancel
Showing results for 
Search instead for 
Did you mean: 

ThunderboltEX II & ASUS Rampage V Extreme compatibility

Szaquak
Level 7
Hello,

I have got short question. Is ThunderboltEX II or ThunderboltEX II/Dual (or maybe both of them) is 100% compatibile with Rampage V Extreme ? Theoreticly YES, but on ASUS product website is not on a list of compatibile Mobo.
Proof: http://www.asus.com/Motherboards/ThunderboltEX_II/ and http://www.asus.com/Motherboards/ThunderboltEX_IIDUAL/
My doubts are raised by the type of TB connector on the board Rampage V and visible on ThunderboltEX II plug (something like USB 2.0, not single-5 pins)
Does anyone of you have a ThunderboltEX II card for ASUS Rampage V Extreme. Does it work?
10,024 Views
9 REPLIES 9

Chino
Level 15

Praz
Level 13

Hey praz, can you tell me what bios version you are running and in which slot you are using for your dual thunderboltex ?

Lobo2515 wrote:
Hey praz, can you tell me what bios version you are running and in which slot you are using for your dual thunderboltex ?

Hello

The Thunderbolt card is in the last PCIe slot at the bottom of the board and the UEFI version is 1201. I have also used other slots and previous UEFI versions without issue.

Praz wrote:


The Thunderbolt card is in the last PCIe slot at the bottom of the board...


Is the card's presence indicated in the System Agent's NB PCI-E configuration?
If yes, is the connection speed x2?


The card's compatibility with R5E is in my case problematic:
1. Windows does not recognise HDDs unless they are connected prior to the system start up.
2. HDDs cannot be ejected via Safely Remove Hardware
3. To disconnect HDDs without freezing the system, their removal via Thunderbolt Management does the trick.

Are you, Praz, experiencing the above?

D.S.O. wrote:
Is the card's presence indicated in the System Agent's NB PCI-E configuration?
If yes, is the connection speed x2?


The card's compatibility with R5E is in my case problematic:
1. Windows does not recognise HDDs unless they are connected prior to the system start up.
2. HDDs cannot be ejected via Safely Remove Hardware
3. To disconnect HDDs without freezing the system, their removal via Thunderbolt Management does the trick.

Are you, Praz, experiencing the above?

Hello

Yes, x2 link speed is correct.

1. I have no issue connecting drives after the operating system is booted.

2. I use the Safely Remove Hardware option and it works the same as if using a USB stick. Have not has any issues.

3. See #2.

Thanks Praz.
It looks like there is something wrong with my Thunderbolt card. It is set in PCI-E 8_2 slot. Cannot use the others as it will disable my system functionality. Temporary switching to other slots does not improve the situation. The card's presence is not shown in UEFI at all.

I'm using WD Passport Pro 4GB split into two drives formatted as ExFAT. Hot plugging in is not working. The drives are recognised by the Thunderbolt management software, but cannot be accessed from the Windows Explorer. I can use them only after restarting the computer.

bryjosh316
Level 7
hi guys just got my Asus ThunderboltEX II but I can not make it work..No I want to use it with my 4k thunderbolt screen.. I am using asus rampage v extreme+ gtx titan z

octavez
Level 7
Hi guys,

I just finished my build it's a Rampage V Extreme (BIOS version 1502) with M2 for the OS. I'm trying to make the ThunderboltEX II Dual work. Here is my current slot configuration:

1: GTX Titan X SC (PCIe 3.0 x16_1)
2: ---- (PCIe 3.0 x8_2)
3: Thunderbolt EX II Dual (PCIe 2.0 x4_1)
4: GTX Titan X SC (PCIe 3.0 x16/8_3)
5: ---- (PCIe 2.0 x1_1)
6: ---- (PCIe 3.0 x8_4)

I tried to put the TB EX II Dual in slot 2 and 3 but both doesn't seem to work (the Attached Thunderbolt Devices window is empty, I tried with a Pegasus R6 and Apple TB Display). It shows up in the BIOS and I can choose the slot. I installed Thunderbolt drivers from Intel website (version 2.0.4.54), it was more up-to-date than on Asus website. I didn't install the drivers that come with the CD since I don't have an optical drive, could it be the reason?

Thank you in advance!