Showing results for 
Search instead for 
Did you mean: 

SM951 M.2 Hangs Just Before Windows Boot

Level 10
Guys, I'm having the same problem with freaking Samsung SM951 M.2. Please read and share your wisdom with me.

Windows 8.1 64bit UEFI
CSM Disabled
Fastboot Enabled
My M.2 is the only device listed in the boot menu

When running these settings:
BCLK: 125MHz
Mult: 32
CPU Strap: 125MHz
CPU Freq: 4000MHz
DRAM Freq: 3000MHz
CPU Cache: 3000MHz
DRAM Voltage: 1.35v
CPU Voltage: 1.275v

50-60% of the time the system hangs after BIOS post with the ASUS logo just sitting there. The error code on the board is Fb which according to ASUS tech support means "System hang on BIOS EHCI Hand-off". When the system hangs I have to restart it several times. On the second or third restart it displays "Preparing Start-up Repair" and it will just hang. Then I'll restart again and it will tell me that the Operating System is unrecoverable and needs to be repaired. I restart again and it boots straight into Windows with 100% stability and zero corruption issues. No amount of BIOS configurations will help resolve this issue. I also tried disabling "Fast Boot" which is one forum user had posted. The data, boot manager and boot loader are fully intact with zero corruption. I also installed Windows 8.1 off the UEFI USB stick 5 times already (getting old).

Now, I have noticed that when I run with these settings
BCLK: 100MHz
Mult: 40
CPU Strap: 100MHz
CPU Freq: 4000MHz
DRAM Freq: 2133MHz
CPU Cache: 3000MHz
DRAM Voltage: 1.2v
CPU Voltage: 1.275v

The boot freezing only occurs maybe 10% of the time at most. I also haven't noticed any Start-up repair messages or OS failure issues etc when running these frequencies.

My brother has the exact same SM951 with the exception that his was manufactured in April 2015 and mine in March 2015. He also has the same motherboard and Corsair Memory brand. He's running his memory at 2666MHz and CPU at 4.5GHz. He has NOT ONCE experienced a single issue with his SM951 hanging on boot or displaying messages about start-up or the OS being corrupted. He followed the exact same M.2, BIOS and Windows installation procedure as I did. I also noticed that user "AdamC" stated, "For the record I have no problem whatsoever with my 512G XP941. Now I am using the XMP profile for DDR4 3000. 5930k CPU at 4.0G (125x32) 1.3V, G.Skill DDR at 3.0G 15-16-16-25-2 1.35V, Windows 7 Ultimate." The vast majority of XP941 and SM951 owners out there don't have these issues.

So the question is, do a few of us have M.2 drives that are more sensitive to clock jitters or that are potentially defective in some way? Why is it that most people can overclock all day long and not have any issues and some of us can't overclock at all without having M.2 hangs and crashes on boot. The instability is ONLY on boot, if by some miracle it boots into Windows while running decent clocks the drive will be ROCK solid without issue.

Motherboard: ASUS ROG Rampage V Edition 10
CPU: Intel 6950x 4.2GHz
GPU: 2x Nvidia ASUS RTX 3090 with EK Water Blocks
Memory: Corsair Dominator Platinum 64GB (4x8GB) 3,600 MHz
M.2 SSD: Samsung 960 Pro NVMEI
Sound: Creative XFI Fatal1ty Champion Series
PSU: Corsair AX1200i

Level 7
Thanks Chino...What about using Windows to setup the array instead of the board? That way I can just re-import the foreign disk if this happens again. I do make backups with Reflect, but would like to prevent restoring if I don't have to. I can restore the m.2 in a couple min. Takes much longer to re-image the array since it has a ton of games on it.


I had basically the same problem - every single time I rebooted it hung on windows load. A trip to the BIOS or a cold boot would often enable it to load up normally. My issue didn't turn out to be a USB problem, it was the SATA controller interface set to AHCI. I changed to IDE and now I no longer get the boot hang. Now, I am using the M.2 as a boot drive and I have 2 drives in a software raid 1. Not sure why AHCI was causing a problem. Do you foresee this causing me any problems in the future leaving it in IDE mode?
Thank you.

Level 9

I have got rid of the problem by unplugging any unnecessary peripherals.