cancel
Showing results for 
Search instead for 
Did you mean: 

Slower internet download speeds

_h___
Level 7
Hello folks,

I noticed that my download speeds are slower by circa 5Mbps on average from other PCs in my house. Even computers connected through WiFi get higher speeds.

I have 20/1 Mbps connection (can't get anything better in here sadly) and while "normal" measured speeds are around 15-18 Mbps (speedtest.net), my desktop with RVE (Intel Ethernet I218-V adapter)
can only climb to 11.6 Mbps max. PC I've build a while ago for my wife runs on P8Z77-I DELUXE (ITX), is connected to same router with same cable, yet can get much higher speeds. Same goes for laptops, hell even cellphones/tablets.

I wouldn't mind this drop if I was running 100+ Mbps connection, however in my situation it's quite significant. I had this problem since the day I purchased the board and was kind of hoping BIOS updates would solve this issue, however no such luck.

Any help is greatly appreciated.

Thank you.

P.S. I tried OS reinstall, driver reinstall, changing settings of the controller itself, nothing helped.
37,281 Views
23 REPLIES 23

_h___
Level 7
No I don't. All of this manufacturer bloatware is useless to me.

fanf74
Level 7
I said that because this software give me the same problem (slow internet connection & unable to download some big files). It desapears when i uninstalled it. So sorry for you.
Do you have software like antivirus or firewall to protect your OS ?

_h___
Level 7
AV/Firewall disabled. I know what can create bottlenecks, however this is not the case. As I've said, I can have everything enabled (AV/Firewall, keyboard software, mouse software, what have you). After fresh installation download speeds are as they should be. Only after I restart the system the problem is back.

i am also having this issue just started a week ago i have done everything from fresh install of windows 10 to drivers

Chino
Level 15
Link me to the driver that you downloaded. Also upload a screenshot of the version and date of the driver currently installed in your system.

_h___
Level 7
Currently I'm using this driver (x64)

Screenshot of the driver version:

44773

Chino
Level 15
Correct. I'm using the exact same driver as you are.

As a test, I went and downloaded the NVIDIA driver and was able to reach my maximum download speed. Restarted the system and proceeded to download the same driver again. All went well without problems. I'm thinking that other factors might be limiting your download speed. Have you tried swapping ethernet cables or resetting your router?

_h___
Level 7
Yup I did, that's basic procedure. I really can't identify why it does this.

Proof that I'm not crazy

Fresh install (no restart):
44835

After restart (minute later):
44836

TSportM
Level 11
i have the exact same problem

but other computers on my network download speeds are great only on the Rampage V a limited to 1.20 mb

also fresh install tryed every thing all fire walls off no av all off

any help please iam going crazy
Rig1 - 14900KS - P112 - E88- MC86- Pcore 6.0/6.2/6.3 Asus Z690 Maximus Extreme - Ecores 4.7 - 48GB TForce 7200#64;7400ddr5 - MSI Suprim X RTX 4090@3070mhz - 24gb memory speed - Powerby corsair Ax1500i - Corsair1000d@custom Loop Rig2- 10920X@4.9 - Aorus X299 gaming 9 - gskill 3200@3600 - Zotac RTX 2080Ti - Powerby CM1200 - Noctua NHD15 black - Corsair 900D

SpoonerUK
Level 7
Under your driver settings in Device Manager, try setting the Speed and Duplex to match what your actual network is providing.
48483

I use gigabit at home, and get my maximum throughput from downloads from the net and local devices on my network.

You could also try disabling QoS in Windows:
http://dottech.org/26628/how-to-force-windows-to-use-100-of-your-network-bandwidth-how-to-guide/


I'm also using the out of box driver on the Asus support disc.
48484
Rampage V Extreme || i7 5960x (127.5x28) || EKWB Cooling for CPU & GPUs || 8x4GB Corsair Dominator DDR4 2800 || 3x 3gb Asus GTX780 || 4x Samsung 840 250GB || Pioneer BDRW || ROG Xonar Phoebus || Corsair AX1500i PSU || Aquaero 5 XT || Lamptron 6 Channel Fan Controller || Razer Blackwidow Ultimate || Logitech G500s || Mountainmods.com - Ascension MASSIVE Chassis || 21x Coolermaster 120mm Fans