cancel
Showing results for 
Search instead for 
Did you mean: 

SLI HB bridge

MikeAdu
Level 9
Hi friends!
Today I was trying to install ASUS HB SLI bridge(4 slot).I put it and started my PC.In windows and other programs everything is working,in nVidia control panel SLI is ON.
But after starting some game in full window I have picture flickering.In windowed mode everything is fine,in full screen flickers all games.I reinstalled video drivers-no luck.So I took this bridge out and put the one which was with motherboard (ribbon cable).
I am planning to return it back to store because I have no idea what to do.
Any help please!
302 Views
7 REPLIES 7

Silent_Scone
Super Moderator
To confirm, there is no flickering with the original ribbon cable?
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

MikeAdu
Level 9
Yes,with original ribbon cable everything is fine.Now I use ribbon bridge.

Silent_Scone
Super Moderator
Return the bridge to the place of purchase for a replacement, sounds as though it's faulty/damaged.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

MikeAdu
Level 9
I have two cards,the bridge version is 4 slot(there is a 3 slot version).
Okay,will try to replace.But what if the issue will be the same?

Silent_Scone
Super Moderator
The 4 slot should work fine, cross that bridge (pun intended) if you come to it.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

MikeAdu
Level 9
Hi.
Got another new one.Everything is working now.[emoji106]

MikeAdu wrote:
Hi.
Got another new one.Everything is working now.[emoji106]


Glad to hear it, although had no doubts. 🙂
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090