cancel
Showing results for 
Search instead for 
Did you mean: 

SATA Port occasionally not detecting Samsung SSD

bryant24
Level 7
Hello all, need some help here. I am running Rampage V motherboard with Samsung 850EVO where the motherboard will not detect the SSD and I have to unplug and plug in again.

Could it be the motherboard SATA port issue? I have tried using a new SATA cable but the same issue occur.*
2,329 Views
4 REPLIES 4

rmongiovi
Level 8
I had intermittent problems with my 850 when I first built the system. A new cable fixed it.

@Chino - Tried but still the same. It happens to my other SSD also.

@rmongiovi - New cable tried but no use.

Brighttail
Level 11
Well if you tried a new cable and another SATA slot and it is still happening, then I would turn your attention to the SSD itself.

Do you have another computer you can plug it in on for a few hours to see if it happens there? I have had SSDs that have had an issue with the power/data plug that plugs into them. It is just a piece of plastic that holds these connectors on and very easy to break /crack them.

The only other suggestion I would have is make sure it is on one of the first FOUR sata controllers of your board. Those will be the closes to the 24 pin connector. Depending on other hardware like m.2's and such, other SATA ports can be disabled or not be on the Intel controller. The first four SATA will always be available and should be auto installed/detected upon Windows installation.

The only last thing you can try is to make sure the MEI and intel chipsets drivers are up to date.

Good luck.
Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz

MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB

Samsung 850 PRO 512GB / Western Digital Gold 8TB HD

Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram

Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop