Showing results for 
Search instead for 
Did you mean: 

RVE10 - Updates, Drivers, BIOS, W10 and SupremeFX HiFi

Level 11
With a whole week off for Christmas I was finally able to update my desktop. Took several days but finally got to a good spot. If you are hesitant to update some of this could be interesting to you.

- MB is RVE10, and I've not updated the BIOS since I first bought it. I was on Ver 1003 last week. So many updates between but I went directly to BIOS Version 2101. For anyone doubting this new version for the RVE10, I have found it to be very stable. I am running XMP with its default values, except I cap my RAM overclock at 3000 MHz. Surprisingly there wasn't that much different in the BIOS options between that very early version and now.

For anyone worried about your overclocks, yes you have to reset, but I have had no issues with the BIOS or Windows upgrade with respect to overclocks. I am still overclocking this CPU to 4 GHz (see my system specs), and my RAM to 3000 per above.

The reason I stayed on that version so long is simply because it worked, was very stable. I was not worried about all the spectre and meltdown talk, etc.

- Upgraded from Samsung 960 Pro 1TB M.2 drive for main boot drive to a Samsung 970 Pro 1TB. This MB only has 1 M.2 slot, and I had a lot of issues trying to make a PCIe card (which I thought was high end) work. In the end I could not boot the computer successfully with it installed in any of the appropriate slots. Never figured out why, so I bought a USB 3.1 drive caddy for M.2 NVMe and put the Samsung 970 in that and worked right off as a USB drive. Could not clone the drive with Samsung's software because it does not recognize it as a Samsung device, but Macrium Reflect works. (Turns out it's nice software so I bought the Home edition on a 1-year subscription). Now I have an M.2 drive upgrade.

- I was holding out with W10 Pro version 1607 till last week (yep, the ooooold one). Same reason, because 1607 was pretty stable. I had been using group policy editor to delay all updates. The updates in W10 were extremely painful and frustrating. It took 3 days overall. Windows refused to do the feature updates back to back. I think there were 5 feature updates for W10 Pro after 1607 but I finally made it to W10 Pro -1909. The last 2 were updated overnight by W10 after time elapsed. W10 rewinded updates about 10 or more times on me, which was very painful. In the end I got it to work.

--- As a result for this board, I had the following relevant takeaways for software:

Asus AI Suite 3 has always worked for me on this board, and in fact still works like a charm after all the Windows updates. I have changed several settings to try and it works like Day 1. I realize some of you do not like this software but I do find it somewhat useful and stable.

EZ Update still works as well, but we all know that doesn't do much anyway.

Asus Aura still works fine on this computer. I have not updated this software for a while and do not know what version I am running on, since this version doesn't tell me anywhere. But I have no conflicts. The BIOS update above did add one option for Aura to be able to shut down in certain sleep states, which is nice.

Asus Boot Setting still works fine.

MemTweakIt still works fine.

Sonic Suite II still works fine on this computer, but I had to reinstall it. Curiously my saved copy of the ZIP file no longer worked. I redownloaded the exact same version from the Asus support page for RVE10 and it installed just fine and works as it did before.

MS Office 2010 Pro I had only a few components plus an Office 365 subscription, and the updates trashed 2010 Pro. Then I couldn't un-install it, and updates kept getting screwed up. In the end I had to download a troubleshooter from MS to sort this out. Lots of time wasted.

Regarding SupremeFX HiFi, I've made a post in another thread about that one. I can't reinstall the Asus SupremeFX HiFi driver I had before. Windows keep reinstalling its own version. I have read about 3 billion posts online about how to completely uninstall and reinstall your own sound driver, but for that one nothing works, put quite simply. So I am using the Windows version of this driver. The HiFi DAC supplied with this motherboard always worked for me and it still does. Great sound output, but like others no worthwhile volume boost to the mic.

I didn't update any of the other software, no need. I did notice that some of my Steam games needed a tweak or two to start the first time, but I think that was more because I also updated the Radeon software to their new major driver upgrade Adrenalin 2020. If anyone else has done that you know that it's a big change.

Perhaps one or two things above will give someone else some assurance it can be done if you are hesitating to do any updates.

Level 11
Added today another fix on the previous updates:

I ran into an issue with the update regarding MS Office. I mentioned in the post above that it ran into issues and had to be fixed with the troubleshooter. This fixed everything except being able to make .docx files start up MS Word with that program as default. All the normal things refused to work to fix this, even after W10 accepted my changes. The icon was a text file and a continuous warning was given that MS Word was not the default editor for documents. Could not be fixed with the simple or the online troubleshooter, and could not be fixed by any UI settings. Apparently this is a problem for a lot of folks who updated W10 and had multiple Office versions installed at some point. MS has no answer for it and in forums simply don't get it. The normal Windows fixes do not work.

The fix turned out to be simple. I went to registry in HKEY_CLASSES_ROOT and renamed the .docx extension to .docxold (could've deleted it, but wanted the settings stored). Then went to a .docx file and changed the default program to Wordpad for all .docx files. That option was not there before the registry change. Then I changed the default back to .docx. This worked, and in the registry editor it added it back in with the correct options.

The first line for the .docx file in the registry that show (Default) had to be Word.Document.12 for me using Office 365, I don't think it was set to that before.