cancel
Showing results for 
Search instead for 
Did you mean: 

RVE10 - PCI-E Light switch dosen't work

Honami
Level 7
Hi,
I'm having a weird issue with my Rampage V Edition 10.
I have a GTX 1080 ti occupied in the first PCI-E Slot and the light on the pci-e switch dosen't turn on to indicate that this slot is populated by a device (Slot 1).
I can POST and boot into the OS (Windows 10) with no issues and everything run just fine. Even in BIOS i have an indication that this slot is active on 16X in NB PCI-E config. The GPU Post however, dosen't show that any Graphics card is connected.
Tried to reset the BIOS, nothing. Tried to turn off the PC, removing the power plug and press the turn on button for a 60 seconds, still nothing.
Sometimes it works but sometimes it's not (for now it's not working for 2 months but worked occasionaly before).
I do use the M.2 Slot for an NVMe SSD but still even with the SSD pluged in the indicator worked before.
Graphics card works just fine on 3.0 16X inside Windows 10. Tried everything even reseating the graphics card (kinda hard as the 1080 ti is under water without draining the system).
CPU: 6900K
RAM: 4X16 HyperX Predator DDR4 3000 Mhz
BIOS: 1903 Latest beta bios
OS: Windows 10 Pro 1803
1,222 Views
0 REPLIES 0