cancel
Showing results for 
Search instead for 
Did you mean: 

Rog rampage v edition 10 bios !503

Darox
Level 9
RAMPAGE V EDITION 10 BIOS 1503
1.Improve system performance
2.Add in turn-off function of LED under S3/S4/S5 status.
3.Fixed Samsung device (SM961, printer) issues.

https://www.asus.com/uk/Motherboards/ROG-RAMPAGE-V-EDITION-10/HelpDesk_Download/
403 Views
10 REPLIES 10

Hopper64
Level 14
Seems to be working fine here. Need some more time with it.
MZ790A Bios 1904, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro

Sprayingmango
Level 10
Installed just fine over here. Everything seems good.

Anyone know if they updated any microcode or IMEI firmwares?

tistou77
Level 13
Microcode is not updated and no news ME firmware 😉
Sorry for my english 😄


Case: Lian Li A77F
MB: Rampage VI Extreme Encore
CPU: i9 10980XE
RAM: G.Skill Trident Z RGB Royal 4x8Gb @4000 C16
GPU: EVGA RTX 2080ti XC Ultra
PSU: Seasonic Prime Ultra Titanium 1000W
OS: Intel Optane 905P PCIe
DATA: Samsung 980 Pro
SOUND: Asus Xonar Phoebus

Catalonia
Level 7
Some fixes for the SM961 nVMe drives. I happen to have one and I had some issues with the boot some times.

Just updated. Let's see how it works.

Brighttail
Level 11
I have two sm961s. Not sure what it fixes as I didn't have issues with 1502 with the m.2 drives, but I did have issues with my memory compatibility. The new BIOS seems to be correcting those issues.
Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz

MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB

Samsung 850 PRO 512GB / Western Digital Gold 8TB HD

Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram

Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

My computer has been just shutting down randomly. It seems to happen if there is a big video load like playing a video game and streaming a movie on the second screen...or when I am video editing in Premiere/AFX. However, it doesn't seem to be overheating and the fans all seem to work. Please keep in mind I am a total novice. I was a sole mac user and this is my first custom PC rig. I didn't even build it myself, I had Micro Center do it for me. I haven't updated the bios since July. Would that fix this? Thanks in advance. My system is:

i75820k
2 x Asus Strix 1080s SLI
64gb Crucial DDR 4 2400 DIMM
Asus Rampage V Extreme ATX2011E
Crucial SSD 960 gb M500
Corsair AX1200I Digital ATX PSU
Corsair Hydro H105I Liquid Cool
Cool Master Storm Stryker Case
Widows 10 with all present updates. 6

Chino
Level 15

afshin
Level 7
when i update bios by ez tools in bios, system do not boot and got A2 error , i have to shutdown my system!
how can i return back to 1501 or lower?

Arne_Saknussemm
Level 40