Showing results for 
Search instead for 
Did you mean: 

Rampage V Extreme POST issues after graphics card update

Level 7

hey all 🙂 
Posting here for some assistance or if anyone has any ideas on what might be causing this issue. 

I've run a Rampage V Extreme for quite some time now. Currently, there's 2 GTK 980's in it & it has run with configuration with little to no issues over the past several years. As it is a bit long in the tooth, I decided a moderate graphics card update would preserve it for a little longer with some much-needed additional VRAM.

So, I bought a 2nd hand RTX 2080 Ti on eBay. The seller has a good reputation & it was a fair price. There's no reason to believe the card is faulty but, you cannot rule it out.

Once the card is plugged into the system, the VGA LED is solid red & this does not change. The BIOS code on it is normally D6 (which is not video output detected). After trying some stuff, I can get is to POST fully but without any display (BIOS code is AA or 40 if resuming).

I don't think this is an issue with HW (bar the graphics card). I have tested with another PSU, Different PSU leads, another power cable & a different wall outlet. TDP for 2080ti is also less than two 980's.
I have tried different display's & different ports on the back of the card. I also tried it in a different PCIE slot. I think I can be certain the card was seated properly. 

I have tried\tested some other things but won't go into too much detail. I did manage to get the card to display but this is after clearing the CMOS & leaving the power off & completely disconnected for a few hours. It doesn't work like that all the time either. The times it did, it black screened on me after about 10 mins. 

For me, it's looking like the card has issues. With the 2 980's back in the machine, there appears to be no issues. However, the seller assures me that it came from a working system. I've no reason to doubt that either.

So, wondering if there is something else at play here? It would be much more convenient if this card just worked.


Level 7

Turned out to be a faulty gcard.