Showing results for 
Search instead for 
Did you mean: 

[Rampage V Edition 10] UEFI boot time / Direct Key

Level 7
Hi everybody,

I have the Rampage V Edition 10 and after getting an M.2 SSD I finally could disable the Intel Raid and thus disable UEFI-CSM. For sure I reinstalled Windows 10 onto the new SSD.

Both of my notebooks boot into windows login screen within 2 - 5 seconds from S5 (power off) state. I hoped my high-end gaming PC would do the same. While booting up got greatly improved by disabling UEFI-CSM It still takes way too long and doesn't look like it's working as intended.

Sometimes the boot logo shows up with the typical "Press F2 or DEL to enter BIOS" text but most of the time it doesn't show up at all and even hammering on DEL doesn't go into BIOS. Fast Boot is enabled (BIOS and WIndows 10) but since it's only active when doing a "Power Off" in Windows and is disabled when just "Restart" I don't think it that something to do with that. The BIOS delay is set to 5 sec.

I haven't overclocked anything and set all possible settings for a fast boot. Sadly I cannot disable SATA Support completely (I don't have any) so I had to set it "Boot Drive Only". I even have disabled both SATA controllers in the PCH Storage settings. After that I wanted to set the USB Support setting. I have Disabled, Full Initialization and Partial Initialization. I want to set it to Disabled to the improved boot speed but then (I guess) I can't access the BIOS anymore.

That's why I checked into the DirectKey feature of the board. At the end of the Boot settings menu is an entry called "DirectKey (DRCT)" with the following description:
[Enabled]: Allow the system to turn on and go to the BIOS setup directly when the reset button is pressed. Connect the 2-pin connector of the chassis reset button cable to the onboard DRCT header to support this function.
[Disabled]: The system will only turn on or off when the reset button is pressed.

I had a really hard time finding this header. I guess there isn't one (or is it on the back of the board?). I then started using the KeyBot II software which includes the DirectKey feature too. I'm sorry to say that but that software is useless. First of all because the functions (I only need DEL to go into BIOS) are ONLY enabled once the software is started, thus you have to log into Windows. If you shut down your PC before you logged into Windows the keys won't work. Secondly it doesn't even work correctly. I pressed DEL for 2 seconds and the PC powered on but instead of going into the BIOS it normally booted into Windows. And finally it only works with basic USB keyboards not - for example - with these Logitech Unifying USB dongles for wireless keyboards. Thank god I had a spare and simple USB keyboard.

Am I doing it wrong?

P.S. In the Advanced > APM Configuration menu I set ErP Ready to "Enable(S5)". I heard that's required to get DRCT working.

Thank you all very much in advance!

aan3kk wrote:
I fully agree with you. The motherboard looks awesome and is even better on paper but once you use it it is just mediocre. The support (I'm talking about the German support) is either completely crap or just for this Mainboard. I created a thread about my issues and linked in my previous posting. Support told me to get the latest drivers for ASMedia USB3.0 from a website of a PC Magazine. Boy, I can google myself. If ASMedia would provide the drivers themself there wouldn't be a problem because I always get the drivers directly from the manufacturer of the chip and not from the Mainboard manufacturer (since those drivers are known to be outdated).

I agree. For my past networking issues, Asus Italy support just linked me the latest Intel driver pack: like I hadn't already tried that!
On the other hand, from my experience, I would just add that generally it is not always wise to use the latest drivers on older components, since in most cases they include fixes and/or optimizations only for recent hardware, which may instead break something on older one.

aan3kk wrote:
I don't have that many issues as you have, maybe because I did not installed any ASUS driver beside the Ai Charger+ (which isn't developed by ASUS itself). I don't use the SupremeFX Hi-Fi but the onboard soundcard but I also use the Windows 10 drivers here. And for the most other parts I directly went to Intel to get the latest drivers.

I did not. Like you, I like a simple and clean environment, so, mainly, I manually install just the actual, strictly needed drivers through the Device Manager.
Furthermore, I use and highly recommend this forum which is a great source of the most recent drivers and general knowledge about Drivers Setup & Maintenance, and also this site from which the former takes a lot, but I advise some caution, as said above.
And I know about the S/W outsourcing, but I don't see why it should bother me as a customer: it's your responsibility as a company to make a functioning product, outsourcing or not.

aan3kk wrote:
'm a long-time ASUS customer (20+ years) and I was always happy with ASUS and the support they provided but now especially the support is pure crap and completely useless and I'm also thinking about leaving ASUS behind and go to a different manufacturer. For sure I had some Mainboards that weren't good, for example one with a nVIDIA nForce 2 chipset. It wasn't ASUS fault but nVIDIA and that's why there's no nForce anymore. Or the P4B533-E which was prone to blown Elkos but again this was a general problem through all manufacturers, that's why we have capped Elkos today.
I do have a second R5E10. The problem there is that the white foil between the PCH heatsink and the LED PCB below is missing, thus the LED light is not smoothed out but you can see the PCB below. Minor problem, easily to fix but ASUS support told me to return the Mainboard to the vendor. After I asked them if they're serious about me completely disassembling my PC just for a tiny white foil and telling them that it's not the vendors fault but ASUS QA failed doing their job they simply replied with how I can RMA the motherboard.

Me too. I have always had Asus MB in my PC, I recognize they have made history in the PC motherboard industry.

Ah, the dear old faulty capacitor affair... been there, done that

This is funny: on my first R5E10, after accidentally touching the PCH heatsink, I realized, to my astonishment, that they used some cheap painting (I guess acrylic) on the LED PCH heatsink cover, because it smeared all over my finger: I mean, Asus, come on...
I could not care less for fricking LEDs, so it was not that big of a deal, however it is sad to see this kind of things.

aan3kk wrote:
Hell, I even bought complete custom watercooling blocks for the R5E10 from EKWB. One monoblock (VRM + CPU + PCH) and single blocks (one for VRM, one for CPU, one for PCH).

ASUS support is not supporting anymore but just redirecting customers to 3rd parties so that they have to care about the customer. I expect more. For a Mainboard that costs nearly 500€ I except even more and especially for loyal and long-term customers I expect even much more.
For example "Dear customer, we'll contact ASMedia to get the most recent drivers. If the problem is not solved with these new drivers please contact us again and we'll happily assist you in solving this." or "I'm sorry to hear our QA failed to spot this flaw. If you are ok with this I could send you either the whole PCH heatsink or just the plastic inlay depending on what you prefer. If that is not what you want I kindly ask you to RMA your Motherboard so we can send you a replacement before you have to send in your current Mainboard."

That's exactly what I think. Simply put, at this kind price, I do not expected to have to tinker and fiddle too much with it to simply work as intended, less than that the thing being broken as it is. There are much cheaper working alternatives on the market.
In the end, I was very fortunate with the returning card management just because it did not involve Asus at all, but just my vendor (Amazon), which kindly accepted a full, uncontested refund (partially thanks to my good status as a buyer), even after six months or so.

aan3kk wrote:
It's the 10th Anniversary of ASUS ROG and they nearly don't support it at all.

Hear hear