Showing results for 
Search instead for 
Did you mean: 

Rampage V Edition 10 Motherboard USB 3.0 & 3.1 Disconnection Issue

Level 7

Its been almost a year, I forgot to post an update. I took my motherboard to our regional asus service center. They found out that the asmedia usb 3.0 controller itself was faulty. There wasn't any issue with driver or windows 10. The usb controller device was causing the issue. Since Rampage V Edition 10 was out of stock worldwide, asus offered me a Z390 Maximus XI Formula. i took it instanlty and purchased a 9900k later. Everything seems to be fine now with the z390 platform."

Motherboard Model: ASUS Rampage V Edition 10 (x99)

UEFI Version: 1801 (Latest Stable)

CPU: Intel Core i7 6800k Overclocked to 4.2 GHz

Memory Kit Part Number (s) and Amount in GB: F4-3200C16D-16GTZR G.Skill Triident Z RGB 3200MHz DDR4 4*8GB = 32GB

GPU: Zotac Geforce GTX 1080Ti AMP Extreme

SSDs: Samsung 240GB Evo 960 M.2 NVMe SSD (OS) & Samsung 850 Pro 1TB SATA SSD (Other Data)

PSU: Cooler Master V850 80 Plus Gold Certified Full Modular 850W PSU

USB Devices:
1. ASUS ROG Claymore Cherry MX Red Mechanical Gaming Keyboard
2. ASUS ROG Pugio Gaming Mouse
3. ASUS ROG RGB Spotlight
4. Creative SoundblasterX Kratos S5 RGB 2.1 USB Gaming Speaker
5. NZXT Kraken X72 360mm AIO Liquid Cooler (Connected to Motherboard's internal USB 2.0 port)
6. Cooler Master ARGB Light Controller (Connected to Motherboard's internal USB 2.0 port)

Monitor: ASUS ROG XG32VQ 32" 1440p 144Hz

CPU Cooler: NZXT Kraken X72 360mm AIO Liquid Cooler

PC Case: Cooler Master H500M

Operating System: Windows 10 Version 1803 Microsoft Activated: YES

Drivers Installed:
1. USB Driver Asmedia_USB3_V1.16.35.1
2. Chipset Driver MEI: V11.0.5.1189
3. Wi-Fi Driver V7.35.317.3 for Windows 10 64bit.(WHQL)
4. GPU Driver Nvidia Geforce Game Ready Driver Version 416.16 WHQL

Any third Party temp/voltage software installed: Currently None. I installed fresh windows to check if it was caused by any app, I haven't installed any 3rd party app yet but the problem still occurs.

System Overclocked: YES
01. AI Ocerclocker Tuner: XMP
02. XMP: DDR4-3200 16-18-18-38 1.35V Enabled
03. CPU Core Ratio: Sync ALl Cores - 1-Core Ratio Limit: 42
04. AVX Instruction Core Ratio Negative Offset: 3
05. Min CPU Cache Ratio: 34, Max CPU Cache Ratio: 34
06. DRAM Frequency: DDR4-3200MHz
07. Extreme Tweaker\External Digi+ Power Control\Cpu Load-line Calibration: Level 6
08. Extreme Tweaker\Internal CPU Power Management\Turbo Mode Parameters\Long Duration Package Power Limit: 4095 & Short Duration Package Power Limit: 4095
09. DRAM Timing Control\Rampage Tweak: Mode 1 (Compatibility)
10. Fully Manual Mode: Enabled
11. CPU Core Voltage: 1.26V
12. CPU Cache Voltage: 1.15V
13. CPU Input Voltage: 1.8V
14. DRAM Voltage (CHA, CHB): 1.35V
15. DRAM Voltage (CHC, CHD): 1.35V
Rest of the settings are left Default or Auto. I've been using this Overclocking settings since late 2016, its been almost 2 years. I spent weeks finding the most optimized manual overclocking settings for my build, so I can confirm that this is the most optimized settings for my CPU and Motherboard.

ISSUE: For the last couple of weeks whenever I connect a device to any of my Rampage V Edition 10 Motherboard's USB 3.0 or 3.1 port the device randomly disconnects for a few seconds then reconnects back automatically in medium or high stress. For example if I connect my keyboard and mouse to my motherboard's back USB 3.0 or 3.1 ports to play games, whenever there's an intense moment full of objects & effects and the CPU & GPU gets a lot of load both the keyboard and mouse stop working for a second or two, even the LED's of the peripherals goes off (Specially ROG Claymore's) and on again while it reconnects. I play competitive games like DOTA 2 & PUBG and believe me this disconnection issue has been the main reason of my deaths and loses since it started to occur. If I connect my gaming speaker to one of these ports whenever it disconnects the sound of my speaker gets distorted and doesn't get fixed until I pull the USB cable out of the motherboard and reconnect it manually. Note that my speaker is a digital USB speaker, so there's no other way that can cause distorted sound.
I couldn't concentrate on my works, play competitive games or do anything with my PC ever since it started to happen. Its been really frustrating for me, I didn't know what's causing it so I started troubleshooting. I tried connecting my devices to every single USB ports and this is what I found:

1. The disconnection issue only occurs if I connect them to motherboard's back USB 3.0 & 3.1 ports marked on the picture below (Top four USB 3.0 and the two 3.1 Type-A below them)


2. The Keybot and USB BIOS Flashback ports (marked below) on the back which are USB 2.0 I assume are completely OK. The disconnection Issue never happens if I connect my peripherals such as Keyboard, Mouse or speaker to these two specific ports.


3. I also found out that the Front USB 3.0 Ports of my case are also OK. The disconnection issue doesn't occur if I connect my devices and peripherals such as mouse, keyboard and speaker to the front USB 3.0 ports. Note that my case has 4 front USB 3.0 ports and they are connected to 2 of my motherboards internal USB 3.0 ports.

Note that sometimes during the disconnections process my entire PC gets frozen and I have to shut the PC down by holding the power button.


STEPS I'VE TAKE SO FAR TO SOLVE THE ISSUE: First of all I disassembled everything from my case and created an open bench setup without the case to analyze the issue. I thought it may have been caused by a driver, firmware or windows itself, so these are the SOFTWARE BASED STEPS I tried:

1. Disabled USB selective suspend settings from advanced power options.


2. Unchecked the "Allow the computer to turn off this device to save power" option of all USB Root Hub including USB 3.0 and all USB devices from the device manager.


3. Reinstalled every single driver separately/one by one which includes Graphics Driver, USB Driver and other drivers that I mentioned above, restarted my PC after every installation or uninstallation process.

4. I tried disconnecting all other USB devices except mouse and keyboard. I connected the mouse and keyboard to motherboards USB 3.0 ports. The problem was still occurring.

5. None of the steps above solved the problem so I tried installing fresh windows 10.

6. After installing fresh Windows 10 I just installed the nvidia graphics driver (as x99 build doesn't have internal graphics) to check if its caused by other drivers. The problem remained unsolved. Then I followed all the steps mentioned above again, still no luck.

7. Tried disabling OC and loading default settings from BIOS, tried disabling USB xHCI controller from BIOS, tried enabling XMP and Auto OC settings from the BIOS, nothing solved the issue.

8. Note that disabling OC from the bios and loading default settings temporarily solved the problem but it still occurred once or twice if I work on my PC for 5-6 hours straight. Then again if I have to disable OC whats the point of buying this motherboard? Even right now my keyboard just disconnected while writing this post althought everything is set to default from BIOS.

These tests confirmed that the problem wasn't caused by any software, firmware, OS or driver. So then I went for these HARDWARE BASED STEPS:

1. At first I tried booting with a single 8GB stick of Memory.

2. It didn't solve the issue, so I started to swap and boot with every single RAM using every possible port individually, it took my entire day but the results were the same.

3. I tried running Windows Memory Diagnostics with every single RAM stick individually and then with all 4 together. The app didn't find any memory related issue.

4. My tests eliminated the possibility of the RAM being the cause of the problem but I still boot my PC with a single RAM stick just to be safe.

5. Then I swapped my Nvidia Zotac 1080Ti AMP Extreme with an AMD Sapphire R9 380x after uninstalling all nvidia drivers using DDU. It didn't solve the problem either. So GPU wasn't causing it.

6. After that I removed my NVMe SSD and tried booting my PC using a completely new SATA SSD with new fresh Windows 10. Tried all steps mentioned above, nothing could solve the issue. Which means the issue isnt caused by NVMe or SSD either.

7. I swapped my Cooler Master V850 with my cousins V750 to check if its a PSU related issue, turns out its not.

8. I swapped my 2000VA digital UPS with another one, I also tried connecting the PSU directly to my wall without any UPS.

9. The only two things I couldn't swap are my intel core i7 6800k processor and NZXT Kraken X72 cooler as I don't have any spare cooler and none of my friends that I know uses x99 based processor. I assume the problem can't be caused by a CPU or a Cooler.

As my last hope I took my entire rig including the motherboard to ASUS Authorized Local RMA Center of our country which is run by Global Brand Pvt Limited. They cleaned the Motherboard very carefully and booted the PC with my peripherals and their test bench PSU. Even thought the PC freezed and shut down a couple of times due to their lower watt PSU but the USB issue didn't occur for a single time. It happens randomly if I keep the PC turned on for a long time, but I could only stay there for a couple of hours. We still tried to recreate the issue within the short time but as it was time to close the RMA center I had to leave. I thought the issue was caused by the dusts they cleaned, so I returned home happily thinking that the problem has been solved. Just when I was about to relax and get back to work using my PC the disconnection issue occurred again. It happens so rarely (like once or twice a day) and randomly that I'm not feeling comfortable taking my PC to RMA one more time and waste their time. What if the issue doesn't occur again? As I'm a PC enthusiast I don't go to RMA very often and I always try to resolve my issue myself, so that would be really embarrassing for me if the problem doesn't occur in front of them again. Now here I am seeking for your help. If there's any possible solution that I haven't tried yet please do let me know, I'd really appreciate that. I'm also trying my best to record the disconnection issue using my tripod and camera.

irahat wrote:

Its been almost a year, I forgot to post an update. I took my motherboard to our regional asus service center. They found out that the asmedia usb 3.0 controller itself was faulty. There wasn't any issue with driver or windows 10. The usb controller device was causing the issue. Since Rampage V Edition 10 was out of stock worldwide, asus offered me a Z390 Maximus XI Formula. i took it instanlty and purchased a 9900k later. Everything seems to be fine now with the z390 platform.

That's the way it is. This motherboard is a case in itself. Without OC should work normally wise:p