cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage V Edition 10 + ExtremeFX Unit (no sound)

russiandivxclub
Level 7
Hi guys quick question. I don't understand what I am missing here. Here is the situation.

I have Rampage C Edition 10 and I just hooked up FX unit. It was collecting dust in the box so I decided to test out it with my Beats headphones. I connected USB to the motherboard (I had to use USB3 to USB 2 adapter cause I am out of USB2, our board have only 2 plugs)

I connected 6pin power and installed drivers. I installed realtek and FX drivers.

Now here is the problem. I don't hear anything. If I connect my headphones to the motherboard in the back or front panel, right away I see windows telling me it see my headphones and RealTek control panel pops up. But If I connect same headphones to 3.5 mm jack in ExtremeFX unit ...nothing happen.

If I select it as default unit and play something , I see bars moving in sound control panel so I know signal is there, at list on the screen, but no sound, and no pop ups like with motherboard/front panel inputs. Any idea on what a hell is going on because I am clueless. I did tried diffirent cheap iphone headphones ... same story front panel works, negative on FX unit.

I did same thing I went to sound control and enable as default internal sound to test headphones , then switched to FX by defaulting it in sound control.

I also selected 3.5mm in SupremeFX control Panel. But again nothing is happening but I see bars moving when playing something, I see it in device manager ... odd

Please help out if you can. Also when opening SupremeFX Hi-Fi Control Panel and selecting 3.5mm or 6.3mm jack and press OK, what should happen ? Because for me, nothing happening. Yet they're talking about test impedance and select high-speed option. Where do I do all that ? Cause in Realtek control panel I don't see it. In my understanding this ASUS Sonic Studio IS RealTek control Panel but with ROG skin and stuff. Because I know RealTek normal panel and it does not look like this, ROG is not there and some other things diffirent.

Here are some images.

Device manager. No yellow marks or anything.


Sound Control Panel showing FX is selected as default unit.


RealTek Audio MAnager as I see it. I see on top it said SupremeFX, but ... I see nothing in terms of ports available on the bottom like they're showing analog ports, rear ports and digital.


SupremeFX Hi-Fi Control Panel, once I select 3.5 and click OK ...nothign happens.



Please let me know may be I am missing something.

Thank you !

P.S.

I did tried to turn a nub, may be it's too low ..... NOPE 😞
240 Views
84 REPLIES 84

I have the maximus VIII extreme assembly edition which, I think has the exact same USB DAC as the rampage V ed. 10. ?

It was working really well before Win10 Anniversary update. Since then its broken down.

I have since managed to get the onboard Audio to work with the original Realtek software (sonic studio) that shipped with the board. However the DAC wont function regardless of what I try. I have since installed the updated SupremeFX DAC software from the support page. I can launch the software and the impedance sense works fine but I still get no audio. After impedance sense is finished and the SupremeFX software runs... I notice If I turn the volume dial the volume does not change on the screen. No amount of tinkering with the volume in windows helps either. Is there something I am missing that will get it to adjust the volume and work??

EDIT -> Got it working with the following steps:
Updated the bios - disabled onboard audio
Removed everything I could related to Realtek + SupremeFX HiFI DAC.
Removed drivers windows was trying to automatically install.
Downloaded latest version of Realtek drivers/SW from the support page for my board.
Downloaded latest version of SupremeFX hifi with anniversary update fix.
Install Realtek then SupremeFX hi in that order. Not working! Noticed through Taskmgr - startup tab that Realtek was disabled on startup.
Enabled it and rebooted and everything has sound and works except sonic studio. But I can live like this for now.

I had installed these versions of Realtek + supremeFX Hifi before but it never worked before.

erixx11
Level 11
great!
after "Creation windows update" I lost my DAC... hellooo

Dear rowpt, wha tis "Downloaded latest version of SupremeFX hifi with anniversary update fix. " I would like to download it...

thanks

russiandivxclub
Level 7
After Clean installation of Windows + all audio drivers + latest Supreme HiFi Controller Panel Driver everything seems to be working now. On first Start HiFi Software correctly calculated my beats Studio Impedance of 130 Oms . Great. AAAAAAAmazing quality when you use good headphones + Panel. I am using 3.5 jack headphones.

davemon50
Level 11
I get the same results, amazing sound quality. Once I used the workaround to get the W10 power options working again (discussed elsewhere on this forum under the RVE10 threads). Only thing I don't like about it is there's no way to boost the mic volume to a decent level even when using a good headset. There's no software for that, even though the mic does work. If I want to use the mic with volume control along with the headphones I skip the SupremeFX and plug into the case using the USB and the inline controller that comes with the headset.
Davemon50

MaacK
Level 7
ASUS honestly doesn't care, this'll be my last ASUS product. Their website is poorly translated to english, their support barely speaks english... After dealing with the audio dac, I completely give up. Never buying another asus again.