Showing results for 
Search instead for 
Did you mean: 

Rampage V Edition 10 + ExtremeFX Unit (no sound)

Level 7
Hi guys quick question. I don't understand what I am missing here. Here is the situation.

I have Rampage C Edition 10 and I just hooked up FX unit. It was collecting dust in the box so I decided to test out it with my Beats headphones. I connected USB to the motherboard (I had to use USB3 to USB 2 adapter cause I am out of USB2, our board have only 2 plugs)

I connected 6pin power and installed drivers. I installed realtek and FX drivers.

Now here is the problem. I don't hear anything. If I connect my headphones to the motherboard in the back or front panel, right away I see windows telling me it see my headphones and RealTek control panel pops up. But If I connect same headphones to 3.5 mm jack in ExtremeFX unit ...nothing happen.

If I select it as default unit and play something , I see bars moving in sound control panel so I know signal is there, at list on the screen, but no sound, and no pop ups like with motherboard/front panel inputs. Any idea on what a hell is going on because I am clueless. I did tried diffirent cheap iphone headphones ... same story front panel works, negative on FX unit.

I did same thing I went to sound control and enable as default internal sound to test headphones , then switched to FX by defaulting it in sound control.

I also selected 3.5mm in SupremeFX control Panel. But again nothing is happening but I see bars moving when playing something, I see it in device manager ... odd

Please help out if you can. Also when opening SupremeFX Hi-Fi Control Panel and selecting 3.5mm or 6.3mm jack and press OK, what should happen ? Because for me, nothing happening. Yet they're talking about test impedance and select high-speed option. Where do I do all that ? Cause in Realtek control panel I don't see it. In my understanding this ASUS Sonic Studio IS RealTek control Panel but with ROG skin and stuff. Because I know RealTek normal panel and it does not look like this, ROG is not there and some other things diffirent.

Here are some images.

Device manager. No yellow marks or anything.

Sound Control Panel showing FX is selected as default unit.

RealTek Audio MAnager as I see it. I see on top it said SupremeFX, but ... I see nothing in terms of ports available on the bottom like they're showing analog ports, rear ports and digital.

SupremeFX Hi-Fi Control Panel, once I select 3.5 and click OK ...nothign happens.

Please let me know may be I am missing something.

Thank you !


I did tried to turn a nub, may be it's too low ..... NOPE 😞

Level 7
This driver situation is completely whack. Has anyone been working on this. What's especially upsetting is that I am installing Windows fresh, which means (as far as I can tell), that I can't revert to an "earlier build." It's 1607 or nothing.

Level 7
I'm also suffering from the same issue... upgraded to Windows 10 Anniversary Update and now my DAC does not work.

Any idea when can we expect a new driver that will fix this issue?

Level 7
I have seen a few posts about this but its starting to infuriate me now.

I cant get past the fact that for the past month since the windows 10 anniversary update no one with this high end rampage 10 board can use the hifi dac or the on board sound.

I have 7 pairs of high end headphones and one of the reason i bought this was the dac , it is actually extremely good when it works about out pacing my modi and mangi uber.
But its unacceptable that ends users can not use it and its been almost 30 days since the update. The dac brings the cost of the motherboard up , the saber dac is not cheap .

This reason alone and the lack of support for this motherboard has be strongly considering just selling it. i got bad taste in my mouth and end users have to worry about driver support if something else breaks.

Being a dev for apps a shipping company uses i would of been fired by now if i did not fix a driver problems within 2 weeks. The service fails to load after sonic sense attempts to find the ohm resistance and its also conflicting with sonic studio.


Chino wrote:
Software team is awared of the problem and is working on a new driver for the DAC.

Appreciate the update Chino. Glad to hear you guys are working on it. Thanks.

Level 15
ZerOxShadows wrote:
This is the most asinine "solution" ever.

Don't up update Windows 10 just to keep an already faulty component functional? Don't update your OS that is still in infancy and don't update to the latest rebuild? Don't update the OS even though competent component manufacturers like Nvidia release drivers that work alongside the latest Windows 10 update. Sure, let's make all the other factors in the PC suffer because Asus can't get their **** together. A beta driver is fine, right? It's not like I paid top dollar for the most expensive motherboard on the market today.

The message wasn't meant to be a solution. More like a heads up to viewers reading/following this thread. If you have the choice to update to the AU, don't do it as it will break the DAC driver. If you've already updated, then use the onboard audio meanwhile you wait for a driver fix. If the wait isn't acceptable, return your motherboard and get one from another brand that satisfies your needs.

I understand your frustration but lashing out at everyone will not solve the problem. 🙂

Level 15

Chino wrote:
Updated DAC driver has been released. It should be up on the Rampage V Edition 10's support page shortly.

You download it from here in the meantime:

you link doesn't work!

Halodies wrote:
you link doesn't work!

Driver still doesn't appear in the Asus Driver download and the link provided by Chino doesn't work...