cancel
Showing results for 
Search instead for 
Did you mean: 

Rampage V 10 edition LED Problem

santz76
Level 8
Hello guys, just installed my rampage v 10 and noticed no matter what i do the PCH led "rog logo" doesn't light up. I have tried every thing i updated to latest bios, tried with aura but still refuses to light all other led turn on and off no prob but cannot figure this one out/ anybody have any ideas?
3,478 Views
3 REPLIES 3

jrmcdou
Level 10
Make sure the led cable is firmly plugged in.
Rampage VI Extreme bios 1503
Core i9 7980XE @ 4.4ghz all cores
64 gb Corsair Vengeance RGB Pro 3600
2x RTX 2080 Ti FE NvLink/SLI
2x Samsung 970 Pro 1tb NVME
Corsair AX1600i
Corsair 1000D case
1x Dell U3818DW 38" Curved Ultrawide and 2x Dell S2716DG 27" 1ms GSYNC 2560x1440 144 hz
Win 10 Pro x64

jrmcdou wrote:
Make sure the led cable is firmly plugged in.

It is firmly plugged in wonder if i can take of the PCH cover or should rma, but to be honest i dont really like all the flashy led's so not sure what to do/

santz76
Level 8
Ok found the corperate when i went to make sure the led plug is firmly plugged the connection behind the rog logo plate over the x99 chip was not plugged into anything can anybody help me can i take off this plate somehow.