Showing results for 
Search instead for 
Did you mean: 

RAM stick not working anymore

Level 7
Hello, so I put in my 16gb of ram that came in a pack together 2 years ago and it was working fine for probably a year or so and I just realized it and im assuming its been a year that it hasnt been reading the two sticks properly. I tried taking both sticks out and using 1 and it'll either give an error 53 or 79. I was thinking maybe one of the sticks were not working anymore and I tried moving the "working" one to another slot and im getting the error and my computer wont even boot at that point. I finally got my rams in the right spot again and my computer read both 16gbs for the first hour then my computer blue screened with a memory error and now only shows 8gbs again. I've always had them both 1 slot from each other for dual channeling.
-Thank you so much for taking your time of reading this!

I just tried to make sure both sticks were in all the way and I tried moving them again and my computer wouldnt boot up till I had 1 stick on the 2nd ram slot. I have both sticks in and the 1 stick in the 2nd slot and the other in the 4th slot and it just detects 1 stick in bios and when my computer boots up.

I tried using the one that I think wasnt working by its self on all slots and no boot up at all.
The "working" one ONLY worked on the 2nd slot of ram and the "nonworking" ram didnt work on any slot.

msi gtx 1080
i7 5820k (with Cooler Master MasterLiquid 120 AIO CPU Liquid Cooler)
8x2 16gb ripjaw DDR4 2133
Asus x99 Pro motherboard
thermaltake 650W PSU

Level 8
if you don't have a second compatible system available, ask a friend or relative to allow access to their system.
then would test both sticks in that system to verify the state of both sticks.
if your RAM tests out okay, would then try their stick(s) in the x99 to try and verify if it actually has bad DIMM slots or just some odd compatibility issue with your particular RAM.

or contact a local shop and have them test both RAM sticks & the board.

what is the warranty status on both memory & motherboard?
ASUS ROG Strix Z590-E Gaming | i7-11700K \ ASUS ROG Ryujin 360 | G.Skill TridentZ 3466 CL14 32GB | ASUS TUF RTX 3080 Ti | M2: 960GB \ SSDs: 5TB \ HDs: 16TB | Super Flower Leadex III 850w | Fractal Design Vector RS Blackout \ 5x be quiet! Silent Wings 3 140mm High-Speed PWM | Logitech G600 | Corsair K70 LUX RGB | Xbox One S Gamepad | Klipsch ProMedia 2.1 | Anker Soundcore Life Q20 | 34" Alienware AW3420DW \ 55" LG CX OLED | Windows 10 Pro x64

Level 12
Error 53 - Memory initialization error. Invalid memory type or incompatible memory speed.
This is where you would have them placed based on the information given.

Error 79 - CSM initialization. Unlikely causes:-
GPU Failure, try using integrated graphics, disconnecting the GPU.
Faulty motherboard.
Faulty power supply damaging other things
Faulty incoming power, damaging your power supply. Inprobable rather than impossible.
Maybe Cause:-
Faulty CSM: Here's a link from Asus on how to remove the need for CSM by switching to UEFI / GPT to potentially isolate the fault:
One you have switched to native UEFI support by switching to a GPT boot disk, your motherboard's Compatibility Support Module will be disabled, skipping the step the board seems to be failing on.

Hope you find this of help.