Showing results for 
Search instead for 
Did you mean: 

Raining Q codes :)

Level 7
Motherboard model:
Rampage V Extreme/U3.1

UEFI Version:

Intel I7 5960x

Memory kit part number (s) and amount in GB:
G.SKill TridentZ - F4-320016Q-32GTZ, 4x8GB kit (rated @3200MHz)

MSI 980ti 6G

SSD/HDDs/Optical drives:
M2 Samsung SM951 - 125GB
Samsung 850 EVO - 512GB
Samsung 850 EVO - 250GB
Bunch of other Sata HDDs
Pioneer Sata DVD burner

Corsair 850 TX

USB Devices (model/version number):
MS Xbox Adapter
3M Ergonomic Mouse
Logitech G502 mouse
Cooler Master QuickFire TK

DEL U3415W

CPU Cooler:
Noctua NH-D15S

Lian Li X2000

Operating system:
Windows 10 Pro x64 activated

Drivers Installed (include version):
Newest from Asus site.

Any third Party temp/voltage software installed:

System Overclocked (provide details)?
All stock (BIOS Defaults)

Hi ROG-ers,

Damn, **** just hit the fan...I had a stable overclock (hours of stress test - RealBench, SuperPI, Mem test, gaming, couple of days uptime), with more than 40 flawless shutdowns/reboots, but yesterday evening I was replying on this thread:, and wanted to try out CSM, thus I rebooted from windows, destined for BIOS to change that setting.
But... I never got there - The system halted with Q code 32 (OC panel stoped on USB).
I've rebooted multiple times, getting different Q codes (98, d6, 95), eventualy got to BIOS where I restored Optimized defaults. After that I am always getting bF Q code (attached picture).
Cant boot to BIOS anymore (even by clearing CMOS).

Guess my memory (or at least one of the sticks) went bye bye, right? It is weird by the way, didn't overvolt anything (DRAM voltage was set to 1.35, with manual timings and speed; CPU set @4.5GHz on 125MHz straop and 1.25V Vcore).

So what am I to do?
First (as soon as my tears dry out) I'll try to reflash the BIOS with Flashback, to rule out BIOS corruption, then test all the sticks, one by one (easier said that done - using big a** Noctua Cooler, which needs to be removed and attached with every change). I think I'll try it out with one new Ripjaws4 16GB kit which I still posses and I am sure it works.
What if that does not work?

Damn, it looks like I am never going to make the system rock solid (with adaptive and speedstep) 😞

Level 8
Hey habbich,

try raising your VCCSA a little bit that should at least make the bF go away.
Also happened to me when migrating to the 2001 version of the UEFI - seems as the 2001 requires a little bit more System Agent Voltage than the previous one.
You should also try to go to the 100 strap, that should also be a lot less problematic (Maybe, and just maybe all your peripheral qcode errors originate from an unstable strap).

Also stability wise, once you are booted the system's stable, right?

Level 10
Have you ever unplugged the power and completely drained the remaining?

Level 40
I don't know what to think BIOSwise at the moment...

I was led to believe BIOS for 3.1 version and vanilla RVE were the same after 1302...but support site for both have been updated recently and only 1302 to 1801 appear on 3.1 site....1701 even has different description...

Remove all USB devices before doing the following of course, if that's what it stopped on originally...something might be up with one of the devices...

Iif things were working fine before just Clear CMOS and/or reflash BIOS BIOS flashback method...

bF is unstable memory but if it was working before I'd try to get it back to working...tweaking if the BIOS has corrupted is pointless


habbich wrote:
I was replying on this thread:

This kind of contradicts the "flawless boots" of this thread :confused:

Kind of suggests Your RAM is not really happy maybe

Arne Saknussemm wrote:


This kind of contradicts the "flawless boots" of this thread :confused:

Kind of suggests Your RAM is not really happy maybe

🙂 without Windows fast boot it was...
Its strange since I could throw any stres test at it and it would pass... Rock stable.

Level 10

Do what adamC said first, just to make sure. You shutdown the computer, shutdown psu, remove power cable and hit the start button on your case. This way, you drain any residual current in the board. Clear CMOS right after. If it still doesn't start, try using the second bios. If the second bios boots, it would mean something went wrong in the other bios so a flashback is in order. If second bios isn't booting too now you might have a real problem. One thing at a time, try these first and report.

Cpu : Intel 5930K@4.25ghz@1.2v / Cache @4.25ghz@1.20v
Cpu Cooler : Corsair H100i
Case : Corsair 780T
Memory : G.Skills 32GB DDR4-3200mhz CAS 15-15-15-35-1T@1.370v
Motherboard : Asus Rampage V Extreme (BIOS 3504)
M2 : Samsung 950 Pro NVME 512gb (Gaming)
M2 : SSD1 : OCZ RD400A 128gb (windows)
SSD1 : Crucial MX100 512gb (data)
Gfx : EVGA Titan X w/ 980 Hybrid Cooling AiO Liquid Cooler
PSU : Antec HCP-1000W
Monitor : Asus RoG Swift

Level 40

Level 7
Damn.. Tried to boot with my other bios chip. Got to the HDD part on OC panel when it changed to POST error with Q code being A2. No boot device?

Weird for sure...since dont get any picture on my screen, BIOS is unacessible.

Also pulled all my USB devices out, cleared CMOS by removing the battery for a couple of minutes with unpluged mains.

Slowly loosing it..I have a feeling that at the end I will find a dead GPU 🙂

Level 40
Sorry habbich...I may be having a bad day but I genuinely don't understand 😮

Your first post the other thread
habbich wrote:
System Overclocked (provide details)?
All stock (BIOS Defaults)

Followed by
habbich wrote:
trying to get a stable OC.

habbich wrote:
I though this has something to do with the OC

Though you say
habbich wrote:
It has something to do with Windows fast boot, since if I disable that option, it does boot normally.

Now this separate thread

habbich wrote:
System Overclocked (provide details)?
All stock (BIOS Defaults)

habbich wrote:
I had a stable overclock

habbich wrote:
I restored Optimized defaults. After that I am always getting bF Q code

Only want to help...

What I would do is strip system...everything USB and disk drive that is not necessary off....maybe one stick of RAM.

Make sure CPU cooler is not too tight...hand tight only

Clear CMOS

Flash 1801 from 3.1 board page...fresh download...from a pendrive after formatting this way

Reseat everything...cables included...make sure 24pin 8pin and 4pin ATX power are connected

And sure...try your other RAM


OK so found this other post :rolleyes: (you do like to keep us hunting for clues LOL)

Basically if you seem stable when in OS but it costs you to get there on boot you are not stable..."seems" stable is not stable...stable OC has no problems booting or running...ever.

Arne Saknussemm wrote:
Sorry habbich...I may be having a bad day but I genuinely don't understand 😮


Bad day and nitpicking... Joke.
Ok point taken, reading through my posts, I can imagine those are a bit chaotic. Sorry for that. Jap my definition of stable seems to be a bit vague 🙂

Will skip to the point..The final goal for me is to have a stable OC. Thus I am always tempering with BIOS. As for the mentioned issues, I've repeated those under default config as well, without any OC. That's why I've wrote it under system config in the beginning of the post.

Anyhow...the weirdest thing just happened. Had my computer off for the past few days (PSU switch on off), since I just could not find the will to go and strip it down and go locate the problem. While I was doing some spring cleaning in my "man cave" I've turn on the computer just for laughs and it POSTed to A2 - but this time with the picture on screen.
F1 to BIOS and loaded System defaults...puff...I'm in windows writing this post.

Was suspicious on my GPU at the beginning, since during all the resets for the issue in this post, there was once an error that my VGA UEFI is not compatible or smth.

Anyhow I am back on route I guess... Starting from the scratch.