Showing results for 
Search instead for 
Did you mean: 

No Post with AMD gpu but posts with Nvidia

Level 7
Hey all. I've looked all over and tried multiple things, still can't get it to post with my AMD card.

Just bought my Powercolor red devil 6800xt on the 15th of Jan, Plugged it in updated the drivers (adrenalin) to 20.12.2 played some games for some time and decided to turn the com off and do some cable managment.

Turned it back on and the resolution was stuck on 800x600 and greyed out, so I used AMD's ddu to delete the drivers so I can reinstall. after that my 6800xt won't post. Plugged in an AMD 7970, won't post. Plugged in an Nvidia 1080 posts and here I'm writing to you.

Used my brother's computer to check the 6800xt and it works for him, with some green screens now and then.

my build:
Asus ROG B550-F gaming Wifi (bios updated to 1202)
Ryzen 5 5600x
G Skill 2x8gb (16gb) 3600mhz CL18
Samsung 970 evo plus m.2 nvme gen 3
Corsair RM 750x - swapped with EVGA 1000p2 platinum
Powercolor Red Devil 6800xt

Things I've tried:
1. AMD ddu delete AMD drivers
2. guru3d's ddu delete both AMD and Nvidia drivers (Nvidia still works AMD not)
3. cleared CMOS, removed the battery and cleared CMOS, mercury cell short-circuit method as well.
4. reseated ram, GPU
5. replugged motherboard power as well as swapped out Corsairs wires with EVGA's
6. formatted my m.2 storage with fresh windows 10
7. checked bios - fast boot is on - boot from UEFI only - everything else stock.
8. tried to install AMD drivers but I don't know how to without having an AMD card installed.

That's all I can think of atm.

To conclude this long post I don't think 6800xt is buggered, because it posts and games on my brother's computer. Two AMD cards are not working on my computer. Nvidia card IS working on my computer.

So.... Please help any and every comment is well appreciated. Will try and respond ASAP.

PS: I will post the fix if I ever get one!!

Level 7
I didn't mention before.

When I turn on the PC - VGA light on the mobo is on.
I don't remember plugging in anything in the speaker slots on MB so I'm assuming that's why I havnt heard any error beeps.

While the PCs on, 6800xt RGB lights are on. I've tried corsairs and evga VGA wires. I've replaced all Corsair wires with evga with no change.

So I've updated bios to 1801(beta) now.. still doesn't work.

removed my storage to see if it would at least post.. nothing.

waiting for someone's input 🙂

I wouldn't recommend upgrading to Beta bios version to test if your GPU works. The 1801 is wonky... I had to flash back to the stable 1202 for my B550-F (Wifi).

That said, is the AMD GPU not posting anything, not even BIOS? Maybe try the different HDMI or Display Port on it. Did you use the DDU tool in Windows Safe Mode? Could be Windows update keeps installing bad drivers, it was only in December AMD released drivers for the 6xxx series.

I did run into a similar issue when I swapped to a Rog Strix 6800xt from a Rog Strix 3090 (it died, apparently 5th one Microcenter got returned...). When I first installed the 6800xt, the PC wouldn't post. It was stock on the White LED VGA for about 2-3 restarts and then it posted. But the BIOS posted with CSM on, as the GPU didn't have any UEFI drivers. This went away after I had installed the drivers for it and then I could take CSM off.

It's highly likely your brothers PC has CSM on. (also, don't install windows with CSM on, you won't be able to utilize Resizable BAR afterwards.)

Momo_dk wrote:
That said, is the AMD GPU not posting anything, not even BIOS?
But the BIOS posted with CSM on, as the GPU didn't have any UEFI drivers. This went away after I had installed the drivers for it and then I could take CSM off.

Hey momo, thanks for the reply. I tried CSM on and off no post. I've tried 3-5+ times to see if posts.

AMD GPUs (both the 6800xt & 7970) don't post to bios while the Nvidia does post to bios and windows.
Used DDU in safe mode. I've used DDU multiple times during this issue to see if it would post without any drivers, but no luck.
Windows update is paused since fresh windows 10 install. Should I unpause?
If bios causes issues ill track back.. but now I just need a post.

Every time I plug in the Nvidia - if the American Megatrends screen pops up telling me all my recognized hardware. It says "The VGA Card is not supported by UEFI driver" and it changes CSM to on.

I've just opened DDU to see what it recognizes. It first tells me the Nvidia's drivers and stuff. Then goes on to AMD:
GPU #001 - Detected Microsoft Basic Display Adapter
GPU Deviceld: PCI/CC_0300
Vbios: NAVI21EXT
Driver version: 10.0.19041.1
INF: Display.inf

So im guessing it does have some sort of driver there. maybe it's corrupt?

Ill try ddu this driver now and restart with CSM on, maybe this combo will work.

Ok so CSM on:
boot device - Uefi and Legacy
boot network - legacy only
Boot storage - leg only
Boot PCI-E - leg only

Fast boot Off

Restarted with my 7970 in it and left it on for about 15mins
POSTED! updated driver to 20.11.2.

It posts straight to desktop. Skipping bios totally. I can't reach bios or boot into safe mode.

On desktop I am stuck on 640x480 resolution. And it's greyed out so I can't change resolution.

Any ideas?

Posts with 6800xt as well with CSM on with 20.11.2 (recommended) display driver.

Turning CSM off doesn't post.

Also, I am unable to reach bios - as it's black screen until the desktop. If I press DEL (to access bios) it stays black screen. If I shift + restart to reach safe mode, it black screens when it comes to the "press 4 to boot to safe mode."

Resolution stuck on 640x480 greyed out and cant change with both AMD GPUs.

Strange... Is there any chance you could install GPU-Z and post its information? Also, your card has dual bioses. Maybe flick the switch on top of the card and see if that does anything different. (One bios for silent mode, another for OC.)

Anyways, you can force safe mode via Msconfig.

  • Go to your start menu, type in MSCONFIG and System Configuration should pop up. Click on it. (If not, press Windows Button + R and type in msconfig and hit ok.)
  • Click on the Boot tab.
  • On there, checkmark the Safe Boot in the Boot options.
  • Click Ok and select the option to restart the system. This should boot you straight into safe mode.

From there do the DDU. Then install the drivers from AMD (they just released new "optional" drivers today, download and save before you boot into safe mode. You should also pick up chipset drivers for the Ryzen.)

Thanks for the reply again momo.

So I thought about it and the only common thing that I didn't change was the monitor itself. And that did it!! The monitor was 10years old and seems to have just craped itself.

Plugged in my bro's monitor and it still gets green screens during startup (ROG logo/enter Bios screen) but after that perfectly fine. I am now able to change resolution, access bios, and enter safe mode with the 6800xt. I have turned CSM off now and still boots. (just imagine if I only had to change the monitor from the beginning................. nahhhhhhh)

To combat the green screen ill try to reinstall drivers first and then change the PSU again back to my 750w gold and see if that does anything. Other than that I feel this case is solved 😄

I kinda don't wanna touch it in case something else goes wrong... but I gotta overclock lol see you soon!