Showing results for 
Search instead for 
Did you mean: 

Missing network controller under other devices in device manager

Level 7
Just installed a fresh copy of Windows 10, because i bought a new m.2 drive. Went through the list of drivers from the asus webpage and installed everything including bios. tried to install the LAN drivers a couple times. Tried to install it through windows update, nothing works.

cant log onto steam. looks like any webpage that begins with https wont connect.

Level 7
tried driver from asus as well as intel

Hello jholt

Have you tried installing the LAN driver from the motherboard DVD?

Level 7
look at this one : WIFI WIN10 32bit&64bit V6.34.223.5

kfc wrote:
look at this one : WIFI WIN10 32bit&64bit V6.34.223.5

Genius! This is what was missing from mine. Very misleading being labelled as an ethernet controller by windows.
Thanks guys for posting this one.

Level 10
I couldn't resolve one yellow sign in device manager first time when I installed drivers and that was some AMDA00 Interface under System Devices...
I installed from modo disk and yellow sign gone.
Sometimes when I enter in Safe Mode if I want to clean display drivers or something else I see yellow mark AMDA00 Interface and when I boot in normal mode no more yellow mark.
What is that... and why is that necessary I don't know.