cancel
Showing results for 
Search instead for 
Did you mean: 

Intel raid driver problems

SpecB82
Level 7

Hello all,

Hopefully this old platiform still gets some love here.  My issue is i have wiped my system to perform a fresh os install with windows 10 22h2.  Im running a samsung 970 evo as my primary drive so i can install win ok if I temporarily disable the primary sata controller.  However I do have two sets of raided drives on that controller and after setting the controller back to raid mode and getting into windows., the rst driver will not install.  I have tried the one from the motherboard support site v14.5 and I have tried 14.8 from winraid forums.  I'm running bios 3802 currently but just rolled ot back from 4101.  

If I force the driver install from device manager using the have disk method, it hangs for a few minutes and then tells me there was an issue with the driver and the disk drives all get exclamation marks.  Upon attempting to reboot windows will hang and require a hard shutdown by holding power, obviously not good...on boot it shows the v14 driver in device manager and the disk drives come to life and the exclamation goes away however you cannot touch the driver, attempting to even disable it will cause it to hang...something is clearly not right.  There's also usually file system corruption from the hard reset and I have to rely on sfc /scannow to try and repair it.

I get that this is an old board but it's supposed to be certified to work with windows 10, and it's not.  Any suggestions on how to get this thing working? Raja or anyone else?

170 Views
2 REPLIES 2

TommyWright
Level 7

Yeah, this is really a nice platform. That's why I joined here. 

Silent_Scone
Super Moderator

Hi @SpecB82 Unfortunately as this is a legacy platform it makes replication difficult. Have you had a look online to see if anyone else is experiencing this issue?

Is there a specific message you receive when attempting to install the driver?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090