Showing results for 
Search instead for 
Did you mean: 

Intel(R) C610 series/X99 chipset USB Enhanced Host Controller

Level 8

I was wondering if you could help me eradicate a sore in my eye that keeps popping up every once in a while:

Anyone with a solution how to get those two Intel(R) C610 series/X99 chipset USB Enhanced Host Controllers properly recognized?

Thanks in Advance 😃

Level 8
I'm fairly confident I am - The ones from the ASUS Website, no?

Uninstalling the Host Controllers and rebooting would have them return with generic naming but still with the Warning Flag.
Installing the Chipset Driver would have them return again to this very state like shown above.

I also tried removing all external and internal USB Devices in case something might be causing a conflict but nope.

Level 8
I HATE the Intel Website with a passion it's unbelievable.
I NEVER find the things I need using their Website.
Beg for mercy should they ever offer me a survey about their Website.

As I'm unable to locate the Drivers on the Intel Website I'm still relying on the Intel(R) Chipset Software Installation Utility V10.0.20 for Windows 7/8/8.1 32bit & 64bit.(WHQL) Drivers from the ASUS Support Website dated at 2014/10/28.

Doing some BIOS Resets I was, for a while, able to get rid of the Warning Flags:

But now they have returned once more - Could Sleep cause this problem?

Very annoying -_-

Level 14
Sleep and other low-/suspended-power modes can cause such issues with "hotswapped" items like USB devices, if they're plugged in when a normal power state resumes. It's much more of a problematic "nuisance" with swappable drives than with USB gizmos, lol.

If nothing is plugged into the intermittently "problematic" USB port then it's basically a poor power design on the motherboard's USB controller(s). Each USB controller (and each USB port) should allocate required power as required when required. But all too often these things are logically isolated but not electrically isolated so some USB devices will hog all available power while others languish in an intermediate half-unawake state.

As stupid as it sounds, I find a lot of USB problems can be avoided by just plugging the devices into different ports, moving them around until a "perfect" configuration (or a better idea about how the onboard port/power allocations are prioritized) becomes apparent.
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams


Level 8
I noticed at some point for the System having issues recognizing a USB Device as it was listed similar to the Host Controllers but I wasn't able to figure out which Device it was before it vanished.

I guess I'll give it a try swapping Devices to different Ports.

Level 7

I just found out that I've got exactly the same issue on a Windows 10 machine. Sometimes it's ok, but very rarely. I can't find the drivers neighter on the Intel website, and trying to install the version you mentioned doesn't work , aven not when selecting a compatibility mode.
Have tried resetting CMOS, no result. Have just upgraded to BIOS 2001, no result (I had it already in 1901 version). Have disconnected all USB devices, no result. Don't know what to do anymore. All help appreciated!

Level 8
I'm currently running Version of the Chipset Drivers from the ASUS Website which appears to have either greatly reduced or entirely solved THAT Issue - Stopped keeping tabs on it though. Besides that Driver I've basically installed every other recent one belonging to the Board except for the Devices I don't use like Onboard Sound, WiFi and Bluetooth.

That being said... The Motherboard is still in a sorry state as whenever I have to either reboot or restart the system it can take up to a dozen tries to get it boot with everything actually working.

Usually whenever it craps out i'll be left without sound but I can already make it out during boot when I hear a faint hissing coming from the Boxes I immediately know the regular Sound Blaster ZxR will not be present once I arrive in Windows 10 - Only the SPDIF Card with the Optical Ports will be there which will then still work but is useless to me as the Software won't work just with that one.

Really don't know what to do about this... Normal Gaming and Working ( 3D Modelling, Rendering, etc... ) is working perfectly! Just the rotten boot not.

I've got version running, and still have the issue with the C610 ...

No issues @ boot however.