cancel
Showing results for 
Search instead for 
Did you mean: 

Hi need help with Asus Rampage V Ed. 10 and Samsung 960 Evo M.2 + questions plz tia

Jcgaweb
Level 7
Hi sirs,
I'm building a new pc after been waiting and saving money for... 10 years.
My last Asus mobo and gpu are still working very nice but can not have over 30 tabs open, luv Asus.
(Intel CPU 2160 @1.8GHz, 4GB Ram, CPU Asus P5B, GPU Asus EAH5570, Crucial M2 120GB, win7 Pro 64bit)

Here is my new PC :
Asus Rampage V Edition 10
2 Strix Gaming Radeon RX480 8GB GDDR5
Intel i7 6850k
32GB G.Kill Trident Z
H115i Corsair Watercooling
Corsair AX 1200i
Samsung 960 Evo M.2 MVMe SDD 250GB
win7 Pro 64bit
No case so far.

But im stucked for over 48 hours, been reading and watching vids, im so lost now with some little worries, as M.2. and others.
I be very gratefull if I could get some help from you guyz. Tia.

My issues :

1/ As I would like to update Bios, i need to install Win7 with a bootable usb key (Corsair Slider x2 flash voyager), can not have this happen.
-Boot CSM => Lauch CSM = Disabled
-Boot Secure Boot => OS Type = Other OS
-Boot Option #1 => UEFI: Corsair Voyager SliderX20
-Boot Override => UEFI: Corsair Voyager SliderX2000A, Partition 1 (60k MB)
Reboot F8, Select boot device, UEFI: Corsair, Enter => getting back to bios without installing Win7.
About the M.2 the tuto on the forum is not for the Samsung 960 Evo.

May i know what do i do wrong tia.

2/ About SuprenFx Hifi installation, can not find a free usb2 port.
There are both in used with Corsair Link Digital for the Psu and the H115i water cooler using the other usb port left.
I'm not too sure to use it anyway.

3/ There are 2 Asus graphic cards Rx480 8go on slot 1 and 3.
The first one with one monitor via Dvi port, the fans are not moving but the other one with nothing plugged in has its fans going on.
I have changed the cards and it always does the same, first card not blowing nothing. Now none of the gpu fans are working but i guess it's normal.

4/ About Drivers to install or not i will follow this tuto :
https://rog.asus.com/forum/showthread.php?92391-Rampage-V-Edition-10-Reinstall-What-drivers-apps

5/ What it the use of the usb devise coming with the mobo.

6/ The modo is placed over a book, is it fine. In fews days gonna buy a case.

Hope you understand my little issues. Super Tia 🙂

65741
65743
6,315 Views
15 REPLIES 15

davemon50
Level 11
Jcgaweb wrote:

Hi sirs,
I'm building a new pc after been waiting and saving money for... 10 years.
...

2/ About SuprenFx Hifi installation, can not find a free usb2 port.
There are both in used with Corsair Link Digital for the Psu and the H115i water cooler using the other usb port left.
I'm not too sure to use it anyway.
...

6/ The modo is placed over a book, is it fine. In fews days gonna buy a case.
...


For your question number 2, I also use the RVE10 and successfully use and recommend THIS DEVICE as a suggestion to expand your capability. Never had any issues with it at all. It also has two USB2.0 external USB type connectors as well, and I use them for my unifying receivers for my wireless mouse and keyboard. The two extra USB2.0 internal headers get me the functionality you are seeking.

For your question number 6, the Corsair 750D would be a great case for you. Provides excellent cooling and space inside. I have the 650D, its predecessor, which is also excellent.
Davemon50

davemon50
Level 11
I also forgot to add this:

I don't know about the H115i - can't find that information - but i do know the H110i has a Corsair Link expansion port in it so you can plug your PSU link wire into the pump, and then use just one USB wire from the pump to a single USB2.0 header to control both the PSU and the H110i fans at once. In lieu of using two USB2.0 headers and plugging them in individually. I would assume the H115i also has this expansion port in it, but online documentation for that model is not as good so I don't know. Might save you one port.
Davemon50

davemon50 wrote:
I also forgot to add this:

I don't know about the H115i - can't find that information - but i do know the H110i has a Corsair Link expansion port in it so you can plug your PSU link wire into the pump, and then use just one USB wire from the pump to a single USB2.0 header to control both the PSU and the H110i fans at once. In lieu of using two USB2.0 headers and plugging them in individually. I would assume the H115i also has this expansion port in it, but online documentation for that model is not as good so I don't know. Might save you one port.



Thx for the explanation but i looked and there is no Corsair Link expansion port.

"For your question number 6, the Corsair 750D would be a great case for you. Provides excellent cooling and space inside. I have the 650D, its predecessor, which is also excellent."
🙂 I have ordered the Corsair 750D, the 650D is great too. You read my mind.

Jcgaweb wrote:
Thx for the explanation but i looked and there is no Corsair Link expansion port.

"For your question number 6, the Corsair 750D would be a great case for you. Provides excellent cooling and space inside. I have the 650D, its predecessor, which is also excellent."
🙂 I have ordered the Corsair 750D, the 650D is great too. You read my mind.


Should be a good case for you IMO. 😉

My new cooler H80i v2 doesn't have the expansion port in it either unfortunately, so I have to use two USB2.0 headers to include the PSU on Corsair Link. Note that if you have no intention of using the ROG_EXT header on the board to attach any other ROG devices, then you can use that header as another USB2.0 also (identified as USB1112). It's a USB2.0 10-1 pin header, but shared with the extra 8 pins next to it for using an ROG device. If you have no ROG device to plug in, then the header can be used as the standard 10-1 USB2.0, so you do actually have two on the board, not one. If you also use the expansion port I mentioned above, you would have a total of 4 USB2.0 headers available. That should be enough.
Davemon50

davemon50 wrote:
I also forgot to add this:

I don't know about the H115i - can't find that information - but i do know the H110i has a Corsair Link expansion port in it so you can plug your PSU link wire into the pump, and then use just one USB wire from the pump to a single USB2.0 header to control both the PSU and the H110i fans at once. In lieu of using two USB2.0 headers and plugging them in individually. I would assume the H115i also has this expansion port in it, but online documentation for that model is not as good so I don't know. Might save you one port.



Yes 4,
2 from usb 3 and 1 from Rog Ext + the usb 1112 🙂

Menthol
Level 14
For Win 7 install go to ASUS support page for a Z270 motherboard, utilities, download - use this for Win 7 install

65779

Besides slip streaming USB 3.0 drivers it gives an option to slip Microsoft's NVME driver into your OS and burn it to a USB drive in UEFI format automatically for you, otherwise you will have to have NVME drivers on a USB drive during installation for Win 7 to see the drive, this APP makes this very simple
Also I don't know if it's necessary but I leave CSM either enabled or auto, OS type - other

Menthol wrote:
For Win 7 install go to ASUS support page for a Z270 motherboard, utilities, download - use this for Win 7 install

65779

Besides slip streaming USB 3.0 drivers it gives an option to slip Microsoft's NVME driver into your OS and burn it to a USB drive in UEFI format automatically for you, otherwise you will have to have NVME drivers on a USB drive during installation for Win 7 to see the drive, this APP makes this very simple
Also I don't know if it's necessary but I leave CSM either enabled or auto, OS type - other


First of all thx you guyz for da help, very kind.
I'm having a really hardcore moment installing win7 via usb3 in a NVMe Sdd Samsung 960 Evo, a nitemare for sure i have spent so so much time for no result.

"Use this tool(V1.02.10) to create a Windows 7 installation file with USB 3.0 drivers preloaded for motherboards."
I have seen that in https://www.asus.com/fr/Motherboards/ROG-RAMPAGE-V-EDITION-10/HelpDesk_Download/

=> Failed, File:\EFI\Microsoft\Boot\BCD
Status : 0xC000000d
info : an error occured while attempting to read the boot config. data.

Did some little changes in bios, hoping good.

=>Doing great, installing but Windows asking for the driver of the disk. I went to Samsung to download, put in an usb stick but can not load it.

Last nite i tried this :

Add native driver support in NVMe in Windows 7 Installation

Windows USB/DVD Download Tool:
http://wudt.codeplex.com/
Samsung nvme drivers for windows 7:
https://www.reddit.com/r/techsupport/comments/3rvoop/samsung_950_pro_nvme_ssd_windows_7_64/
Windows 7* USB 3.0 Creator Utility:
https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility

Then i got this :
"Select the usb flash drive screen capture failed, usb flash drive with Ntfs or exFat format is not supported"

I thought it was cause of the usb stick was larger than 32gb so did it with an usb2 4go, same result.

the is that from Microsoft too :
https://support.microsoft.com/en-us/help/2990941/update-to-add-native-driver-support-in-nvm-express-...)

With x99, there is no need to change the win7 image cause the usb ports can be EHCi, anyway, im lost.
I must admit, this is difficult. Any help be really appreciated, tia 🙂

Jcgaweb wrote:

Then i got this :
"Select the usb flash drive screen capture failed, usb flash drive with Ntfs or exFat format is not supported"


Try using FAT32.