cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Strix MB (RESOLVED): Hail Mary on USB Port Power Issue

Mr_Savy
Level 7
I spent a number of additional hours trying to resolve this issue including:

- reducing hibernation file size
- loading ASMedia Driver v1.16.26.1
- loading ASMedia Driver v1.16.41.3
- Bluetooth removal
- reloading all USB controllers and reloading
- uninstalling Corsair Link 4

Yesterday March 5, I was within minutes (literally) of resetting the PC when I noticed Microsoft's release of KB4090913. The release notes say "Addresses an issue in which some USB devices and onboard devices, such as a built-in laptop camera, keyboard, or mouse, stop working. This may occur when the Windows Update servicing stack incorrectly skips installing the newer version of some critical drivers in the cumulative update and uninstalls the currently active drivers during maintenance."

BINGO!!!

Updated W10 to v1709 Build 16299.251

So this update not only fixes an issue introduced in KB4074588 but older issues like mine.....

So I'm very happy I didn't reset and reinstall about a 100 programs!!!

I'm crossing my fingers that this fix is permanet but you never know for sure. I may be back with sad news.

********************************************************************
I need the expertise of this community. I'm at the end of my troubleshooting skills. I am trying to avoid the potential ultimate solution which is to reset the PC on my Windows 10 machine.

Problem: After the computer sleeps for awhile AND then rebooted sometime later, the computer will go through the boot sequence but when it gets to the logon screen there are no powered USB ports. This makes it difficult to log in, like can't. Nothing I do in the bios will fix the issue.

Work Around: I boot to a USB drive with Windows Repair, restore from a fairly recent Restore Point (note: repairing Windows doesn't ever find any issues). Reboot and everything works. However not every RP works, only some. Some RP's where I was careful to update virus, windows, drivers (where needed), etc after no USB but b4 creating a RP, won't work. Seems like they should. The no USB port after boot sequence will still occur the next time I boot.

What I know: If after I restore, do a short sleep then reboot, no issues. So it seems to occur after longer sleeps. For sure overnight. Why a restore works and some don't, can't figure that one out.

MY SYSTEM:
Asus Strix MB, latest bios, UEFI
Intel 6800K
EVGA GTX 970
Corsair Dominator Platinum DDR4 3200 16G
Boot Drive: Samsung 960 Pro m.2
Windows 10 Installed from scratch early 2017
Running latest W10 version
Corsair M800 Game Pad
Corsair Platinum K95

Things I've tried (seems like everything):

Tons of internet searches. Others have had this issue. When they have found solutions, they don't work on my system. Tried what I think are most of the other suggestions out there. Hopefully I just missed one.

Disconnect all USB devices except keyboard and mouse + all drives except boot drive
In bios setting various of:
C-States
Fast Boot
USB xHCI
Default bios settings
CSM Launch
I'm sure I missed sharing other settings I've tried

In W10
USB Power Mgmt (unchecked all allow computer to turn off)
Updated ASMedia USB3.1 eXtensible to v1.16.49.1 (tried other lower version drivers)
Bluetooth Qualcomm & Microsoft drivers
Adv Power Options (Drive sleep never, no hybrid)
Ran chkdsk, no issues
Ran sfc /scannow, no issues
Event Views shows a reasonable number of DistributedCOM errors (I know how to fix them, fixed some b4, but don't think that's the issue)
Since I've owned the Strix, I always get Event 137, "system firmware has changed the processor's memory type range registers (MTRRs) across a sleep state transition (S4). This can result in reduced resume performance. However this USB issue is something I encountered around the November time frame
Always keep W10 update when updates are available
Always keep virus & malware up-to-date (NIS, Malwarebytes)
Always keep software Up-to-date

For awhile I though the issue maybe either Logitech Gaming Software or Macrium Reflect (maybe an update). Uninstalled but same issue occurs. Some people have thought issues were generated due to the Fall Creators update of W10. So maybe that's the issue.

System works pretty well if the computer is never rebooted.


So this is my hail mary to you experts. I'm trying hard to avoid a PC Reset because it is super painful. Lots of applications and take15-20 hours to get back up and running. Want to avoid at all costs but I may be destined to do that. I'm hoping there might be a registry change that can be an easy work around.

Thanks in advance for any ideas!!!
2,883 Views
1 REPLY 1

xeromist
Moderator
Glad you figured out a solution! That sounds like it was a head scratcher for sure.

***Please maintain one thread per topic. Your extra threads have been deleted. Thanks.***
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…