cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Intel® Extreme Tuning Utility

Mikan02
Level 7
http://www.asus.com/Motherboards/ROG-RAMPAGE-V-EDITION-10/HelpDesk_Download/
Have issues trying to install Asus XTU on my RVE10´s
OS on both is a clean install of Windows 10 Anniversary Update with Secure Boot on:>
Found this thread at Intel with people that have same issue after clean install Windows 10 AU.
https://communities.intel.com/thread/105240

Any ideas?
65,148 Views
11 REPLIES 11

Menthol
Level 14
Do you have Intel MEI drivers installed?

Mikan02
Level 7
@Menthol
Yes I had that installed already, tried even to uninstall and reinstall MEI.
OS still refuse to accept the driver. 3rd post on the Intel thread I posted show same message I get after install.

Qwinn
Level 11
Yeah, the digital signature thing is a bear for clean installs of AU. Intel was definitely surprised by it. It affected the Intel 750 SSD driver for a while as well. Here's where I reported it, and they did get it fixed:

https://communities.intel.com/thread/105326

I'm surprised they're resistant to the answer, as they copped to it right away with the SSD driver. Maybe if you post a link to my thread in your thread, that'll get the two groups over there talking to each other and figure out how to fix it.

Until they get the XTU drivers signed, I'm guessing your only workaround will be to disable secure boot, or roll back Windows to before the AU update.

meankeys
Level 13
Try installing your chipset driver again reboot the the MEI

Mikan02
Level 7
@Chino
Tried to run as admin couple times, result was same.

@meankeys
Tried that just now, same again sadly.

@Qwinn
The Intel thread is not mine, found it when googling the issue. Thought I link it to show others with XTU and clean install of Win 10 AU had issues too.
Looks like you are correct thou. Think I will wait until it is fixed, hopefully Intel comes with a fix soon. ^^

Thank you for the replies everyone:)

Vlada011
Level 10
Because of that I'm still on Windows 7 x64 and next time I will install again Windows 7.

Saijohn
Level 7
Seems like it is not really intel's issue but windows 10 anniversary update. Some people also mentioned that there's an issue with installing Samsung Magician after the anniversary update.
Quick question, is this Asus XTU exclusively for Rampage V Edition 10?

Qwinn
Level 11
XTU is Intel, not Asus.

And the issue ultimately has to be fixed by Intel, tho the AU update caused it by imposing much more stringent digital signature requirements for all drivers, not just Intels (only on clean installs of AU though, updating to AU from 1511 grandfathers the drivers in. Updating 1511 comes with a different set of problems tho, i think clean install is the better way to get AU even with this issue.) Intel has to get their XTU driver signed like they did for the Intel SSD driver I linked about. It's not a bug, it's MS trying to make secure boot even more secure, now all the driver makers have to register their drivers with MS so they will work. To their credit, Asus appears to have been on top of this change and gotten their drivers signed, I had no problem installing any Asus drivers due to this issue, even the ones released very recently.