Showing results for 
Search instead for 
Did you mean: 

Zenbook update BIOS goes wrong,error code 10 in IMEI in device manager

Level 7
Hi ROG forum.
I tried to update BIOS to my Zenbook UX31A due to some CPU issues, I am at Windows 7,laptop is too slow for W10.
I downloaded the latest BIOS file from UX31A support website from asus,copied the flash sile to USB pendrive,went to BIOS and choose START EASY FLASH and ran F0 pressed ENTER and it started the process of flash.
I got message that previous flash file was erased and at the end of the flash I got the following message (pic below).
I could not exit from that screen so I switched off the laptop and after power ON, it could not boot into Windows.
I had to format and install Windows 7 again but after that now I see exclamation mark near power managment (pic below).
I did install all the drivers from the support website.
Could this exclamation mark be a sign of corrupted BIOS flash?
I think I already had latest BIOS and probably I did not check that and tried to install previous version over newest one.
I suppose that is the cause of corrupted flash or smth else?
Now I am worried more about that exclamation warning for IMEI.
I am at BIOS version UX31A.219 now.
Laptop works so far okay,no issues I hope...