Showing results for 
Search instead for 
Did you mean: 

TUF FX705GM WiFi code 10 error - resetting BIOS doesn't work

Level 7
I'm suffering from this apparently infamous Code 10 error with the Intel AC 9560 WiFi card inside my ASUS TUF FX705GM laptop.
I've tried almost every solution I can think of or find to fix the issue; updating to the newest driver, using an older driver, reinstalling the driver, updating Windows, resetting the BIOS and restarting a few times; nothing seems to be working for me.
I had the laptop sent in for RMA a few weeks ago to see if ASUS themselves could fix the issue, and they did. They mentioned in the repair report they sent me something about changing the network stack setting in the advanced BIOS settings, which was causing the issue. I can't remember exactly if they turned that setting on or off to get the WiFi to work, but either way I've tried both on and off to no avail.
One thing I did with the laptop after I got it, and again after it was sent back from RMA, was configure the laptop for dual-booting with Windows and Manjaro (Linux distro). This requires changing a few settings in BIOS to allow the laptop to boot into Manjaro, and then back to original settings to allow Windows to boot.
The question I have then is this; is the dual-boot somehow preventing even a BIOS reset from fixing the WiFi error, and if so, are there any other solutions I could try (maybe buying a new AC 9560 card and swapping it out) or should I just scrap the idea of dual-booting entirely?

EDIT: Bought a new Wi-Fi card and it worked for about a week or two, but now I'm back to the same issue.

Level 7