cancel
Showing results for 
Search instead for 
Did you mean: 

N75SF wont Power On and has no LED when AC connected - HELP NEEDED!!

JamieBrix
Level 7
Hi all,

First up thanks for all the info as i have found the forum very useful over the years, so really hoping someone can help me now as my everyday N75SF with all my work on it has become totally INERT!!



Basically I encountered a BSOD during a standard Win 7 (64) shutdown after failing to flash the BIOS up to date with WinFlash. I was going to try it in Safe Mode (as had not had any warnings from WinFlash) - obviously that was a bad idea! It hung on the Win 'shutting down' screen for c 15minutes and then BSOD'd so fast i couldn't take a picture before it had gone and then refused to start up properly...

At that stage the AC LED was green and the Batt was in and fully charged. Tried thrice to start her up and only got one beep and the fan sounds with a black screen and no other activity even when i left it for ten minutes. After that i tried unplugging and removing Batt and leaving for 20m. Since doing that I now don't even get the AC connection LED and pressing the power button does sweet FA: no light, no sounds, its just a totally inert lump o plastic.

ANY HELP, SUGGESTIONS OR ADVICE VERY GRATEFULLY RECIEVED!! I was about to open it up and have a poke around as it seems a hardware problem, but am not very experienced in doing so and would have no clue what I'm looking for or trying to achieve!
________________________________________________________________________________________________________________________________
Asus N75SF

Bios version: was 204 and failed to update to 214 (https://www.asus.com/support/Download/3/363/0/1/HpJUtvdEEkdI1xBC/8/)
CPU: Intel® Core™ i7 2670QM/2630QM Processor
Memory amount in GB: 8gb
GPU: GeForce GT 555M
SSD/HDDs/Optical drives: standard HDD it shipped with - 500gb SATA

AC Adapter: Original & Working fine (light's on)
Operating system: Windows 7 x64 (Original ASUS factory image & Microsoft Activated no)

Drivers Installed (include version and especially any non-ASUS approved notebook drivers):
Standard with recently reinstalled 'latest' NVidia ones from the Asus support page - Version V8.17.12.6874
[Had been having problems with the NVidia drivers that led me to update the BIOS, or try at least!]

Any third Party temp/voltage software installed: no
System Overclocked (provide details)? no
Any hardware upgraded? nope

Issue (In addition to above i had had problems with the NVIdia card & drivers that i was working through, so had been running Speccy and CCleaner and such trying basically to avoid formatting it and starting fresh. Basically it was BSODing on almost all games including ones it used to run no problems, such as say Rome Total War 2. Otherwise just the usual building slowness to boot etc.)

As i say any help greatly appreciated and ANYTHING you want to know just ask - I really need to fix this as I run a small business and use the laptop all day everyday for that as well as games and such.

Cheers for reading,
Jamie
4,631 Views
5 REPLIES 5

cl-Albert
US Customer Loyalty Agent
Hi,

Sorry for the delay.

If something went wrong while you were trying to flash the bios, that's usually bad news although it's not clear if it really even started the bios flash procedure (which may have happened on the Windows restart)?

Anyway, try to get into the bios by tapping the 'delete' or 'F2' key as soon as you power on and maybe connect an external monitor if available to try to get a display (Fn+F8 may switch the displays if necessary), but don't have a lot of hope for this and it's very bad news for the hardware if you cannot even get into the bios anymore (which may indicate something really did happen to the bios somehow).

If you're not even able to get into the bios, this idea may not work, but try holding the 'ctrl' and 'home' keys while you power on the unit to see if it will start the bios recovery/re-flash procedure which will look for the bios file from your C: drive that is included as part of the ASUS Windows image for models that support this feature.

If you can't get better ideas or a solution though, you may want to start consider sending it back to ASUS for repair especially if you are still under warranty, otherwise, you might need to decide if you want to pay for out-of-warranty service.

http://www.asus.com/support/callus

If you didn't already know, you should be able to remove your hard drive and transfer the data to another computer using a USB hard drive housing, so something you may want to look into or find a repair shop to help with.

Good luck!

Thanks for the time and reply cl-Albert,

I have had it in a repair shop for the last days and they have just confirmed that it is in fact the GPU (the 555m) not the motherboard and so whilst i save £90 on a repair bill I'm down a decent laptop. My fault for persisting with CoH2 I'd say!

Nevertheless you make a good point with the external usb HD housing which I didn't know of and seems like a good option versus paying a similar amount for the repair shop here in London to do it for me, so once again thanks.

Another question arises then - I've seen a tempting deal on a ASUS ROG G750JS - would any elements of the old N75SF, such as RAM and HDD, be compatible with a more modern ASUS ROG like the G750? If so I would likely keep them as spares.

Cheers for reading,
Jamie

cl-Albert
US Customer Loyalty Agent
Hi Jamie,

You may need to physically check your N75SF unit, but if it is using normal DDR3 so-dimm memory, you don't want to use it for the G750JS which will be using the lower-voltage DDR3L so-dimm memory or mix the 2 different types of memory.
Below is more information about DDR3L memory from the G750 notebook section if you're interested.
https://rog.asus.com/forum/showthread.php?33744-Upgraders-1-35V-memory-is-required!

If may also depend on which version of the G750JS that you are using since you may not have extra hard drive bays, but if you did have the space, it's likely you could use the 2.5-inch notebook hard drive from your N75SF at least.
Otherwise, you could always use that N75SF hard drive as an external drive if you get a USB housing for it.

Well, you may want to double-check my information or discuss with others since it's not always easy for me to keep up with all the different models and versions we have, but hope it helps.

JamieBrix
Level 7
It does help, and is appreciated, thanks cl-Albert.

try removing battery..unplug charger...hold the power button for 5 -20 seconds (drains out the circuit current)....plug the stuffs back in and there u go its on !