cancel
Showing results for 
Search instead for 
Did you mean: 

N55SF : lost home Wireless network after recommended update of BIOS

wagedu
Level 7
Hi all,

I just bought a new ASUS N55SF 2 weeks ago. After a while I accepted the "recommended updates", which included BIOS and Wifi. Before anyone asks: I was able to do so because he computer was wirelessly connected o my home network.

After the upgrade, I can only see my home network briefly. As soon as I ry to connect to it, disappears from the list of available networks.
So, I tried a drivers update. No luck, same problem.
Then I tried restoring o factory state. No luck. So, since the BIOS is the only hing that can't be resetted, I think of it as the potential problem.
But... there's no way to DOWNgrade BIOS on that machine. Have looked for and tried even afudos... but ASUS Bios files (downloadable from their site) are in the format NAME.VERSION (N55SFAS.203 for instance) and not NAME.ROM

And yes, all other machines at home can see and connect to the network, no probs at all. They are a Win7, a Mac Snow Leopard and a Mac Lion.

Anyone can help/offer some support on this?

Thanks in advance 🙂

Just to check, I decided o install OSX on the 😧 partition. And it connects over WIFi without problems! Same machine, Windows doesn't connect, OSX yes.
What can I do?!
14,858 Views
12 REPLIES 12

fuzon1337
Level 10
Haha, yeah I should have mentiond that just to skip the part to reset CMOS, this was posted due to a issue on the G74 notebook for another member in this forum and somehow this have worked to restore BIOS when it has been bricked...

Not exactly sure me neither but I think he means that you should leve the usb stick in the notebook when turned of for 15 - 20 min then boot up and hit ctrl + home then it would reflash the BIOS with the file from USB thumbdrive.

If you click on the blue arrow in the quote then you can see which thread I found this info from 😉
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205

Well, didn't work either.

I'll plug a 20ft ethernet cable on the meanwhile. If the BIOS is so "user resistant" I guess it's better not get over my head.

It's a defeat not the end of the war, hehe

Thanks for everything, you were extremelly helpful!

fuzon1337
Level 10
I'm sorry for that none of my suggestions worked out for you 😞

Then let us hope @MarshallR have a suggestion that will work for you 🙂
Asus G73SW-91058V 3D
- Intel Centrino Ultimate-N 6300
- BIOS 205