Showing results for 
Search instead for 
Did you mean: 

Looking for: ASUS TUF F17 FX706HE factory image

Level 8

Hi everyone.

I´ve formatted my laptop, but now I´m in the need of a copy of the original recovery partition/system image/Cloud recovery.

I´ve searched the entire web, without finding anything. So I am now asking you good people, if anyone can help me in my search.

Thanks in advance.



Accepted Solutions

Level 11

I don't know if I understand the question
but here you can download the Windows operating system and install it

I know where to find Windows OS images, but that is not what I am looking for. I am looking for the factory standard image of the laptop. As if it just came out of the factory, with all drivers and programs from ASUS already installed, with MYASUS WinRE, cloud recovery and everything out-of-the-box.


As far as I know, there is no way to download a factory standard image once Windows has been reset.  You can still reinstall all the ASUS programs from their website, which would probably be better so you can pick and choose what bloatware you want to be using your system resources.

I already know that too, but one with the same model can make an image of theirs. Didn't know I had to go that much into details.


Just out of curiosity, why would you want to do this?  You are aware that having more programs installed is going to result in a worse experience, right, unless you're planning on using every single program that comes factory installed (including McAfee)?

Because the only time my gamevisuals were working, was from factory standards. It haven't worked since the first time I made a clean OS install. And I won't give up my laptop to RMA for 3 to 5 weeks. McAfee is not a problem to remove totally for me.

Ah, OK, well I have no experience with GameVisual, so good luck finding a factory image or a fix for it.

I found this thread, maybe it will help: PSA: A fix/workaround for "GameVisual may not be supported" issue. : r/ASUSROG (

I actually found a German site containing different ASUS images. Regarding the link you sent, I've already tried that and many others, without any results. My theory is that the original internal monitor driver, gets overwritten by some standard windows driver instead. But it is not showing so I can't roll it back either.

I am glad you solved the problem.

Could you write the link to this German site?