cancel
Showing results for 
Search instead for 
Did you mean: 

Asus TUF Gaming A17 FA707XI - bios update 308 and later refuses to install

WastedJoker
Level 8

Hi,

Bios version 308 was offered yesterday through My Asus. After rebooting a message appeared saying "Please wait while we install a system update" but after giving it almost an hour to complete I resorted to forced shutdown. I've subsequently tried this 3x to no avail.

I've also tried manually updating it via the Bios installer utility (located here when My Asus has downloaded the update: C:\ProgramData\ASUS\ASUS System Control Interface\AsusSoftwareManager\AsusLiveUpdate\Temp\1\

Absolutely nothing happens when I try that method.

I've also extracted the update file to usb drive and tried installing it via EZ Flash but after you request the install the system just freezes.

I think perhaps the file is broken and needs to be redeployed by Asus at this point.

4,224 Views
40 REPLIES 40

Foxabilo
Level 9

Got the same problem, my asus keeps alerting me to a 308 bios update and when it reboots to do it it's stuck with a blank screen, it never occurs, I suspect either the file is corrupt or the updater is.

Foxabilo
Level 9

Actually... it says version 308.. the asus website is only 304? I wish the website would not keep changing the model number from FA707XI to FA707NU. The entire site needs an update.

WastedJoker
Level 8

Still no luck with these even though the 308 bios was offered through the non-essential part of myAsus.

 

Exact same issues happen

I think they are having a laugh at our expense,

I contacted support and got told to send my laptop in for inspection.... as in, Fed ex my laptop to one of their repair centres to get lost for 6 months to check a software problem. 
I love Asus hardware but their support is the worst I've ever delt with. 

My advise for anyone else reading this is to uninstall MyAsus and just do everything by hand manually, the website for updates has no bios 308 for the FA707XI, if you did manage to install it, it would most probably brick your laptop and then you would have to send it in for repair.

Let me ask you, have you upgraded your RAM and SSD by any chance? I'm thinking Asus may have forgotten that people do occasionally upgrade things. I'm thinking maybe the UEFI system is borked for updates now that the old slow tiny 512Gig drive has been upgraded, not moved in it's slot, just left in place and a new drive added and then 32gigds of 5600 put in...

Yeah I upped to 32gb ram and added a 1tb nvme drive

I'm willing to bet that has something to do with it, whatever team is doing finial compatibility QA is... well they are not doing it at all, they just test with a vanilla machine and call it good. 

Maybe but I'm not willing to remove them just for the update !

With you 100% there, I've just ordered some 16Bg USB Sticks as apparently you need one to do the manual update, if you download the .308 file from the webiste and copy that to a USB Stick then you can reboot the machine and hold down F2 to get to the bios and then go to the advanced tab and then to the EZ Flash utility and pick the USB stick drive from the list and it will do a manual update, this would be a lot simpler if I had easy access to all my old gear but a recent house move means everything is in box's so I dunno where my USB stick are.