Showing results for 
Search instead for 
Did you mean: 

Asus tuf f15 fx506hm wifi problem

Level 9

MediaTek Wi-Fi 6 MT7921 Wireless LAN Card disappear no wifi in Task Manager error code 45 in Device Manager, wifi driver are updated to last version my operating system is WINDOWS 11 AWUS1900 Wifi Adapter work with no issues !!!


Level 11

Press and hold the power button for 60 seconds (min). It will reset the hardware detection and will most likely fix the Wi-Fi.


Level 9

I don't know what make the MediaTek Wi-Fi 6 MT7921 show error 45 in DEVICE MANAGER but right click and scan for hardware changes fix the problem for a while and wifi disappear again and again it is driver issues for sure no fix I did everything changed registry PLATFORMAOACOVERRIDE to 0 all power option and plans showing up DISABLED Allow computer to turn off this device to save power Wireless Adapter Settings already at Maximum Performance

- unplug any USB devices
- turn off laptop
- press and hold power button for 60 seconds
- release power button and restart the system

Solved yes or no?

No it didn't solve the problem

Level 11

then if you have win11 try updating both the Wi-Fi adapter (3.3.760 WHQL) and Bluetooth. A videó az alábbi gépen készült: Asus ROG Strix G713QM-HX1139T Alaplap: Asus ROG Strix G17 G713QM Processzor: AMD Ryzen 9 5900HX with Radeon Graphics BitLocker modul:AMD PSP 10. Device TPM 2.0 RAM: 2x16GB KINGSTON ...

I did update to this drivers before nothing work same problem 😁

Level 9

Ok thanks

I disabled Mediatek MT7921 wifi and Bluetooth in BIOS it is annoying I use AWUS1900 and have no issues

Level 11

many users have solved this problem
pressing the power button for one minute
or by installing the drivers
MediaTek Wi-Fi 6 MT7921 Wireless LAN 3.3.760 WHQL drivers
Bluetooth MediaTek 1.930.3.287 WHQL
(this operation is however different from updating the drivers).

Some have solved all problems by changing the wireless network card, (which is also faster).

Other than that I don't know what else to say, maybe you could contact Asus support.

I'm from Egypt AX210 not available 😐