cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS TUF A15 FA506 battery working but not charging issue

Mabus1984
Level 7

Yesterday I discovered that my laptop no longer charges. The battery is still working however is now in the red and i can't imagine it fully booting if i put it back on.

I tried the hold power button down for 60 seconds. I opened up the back and checked the port, which is in rigid, albeit the power cord doesn't fit in snuggly but rather wiggly. There is no dirt in the port.

I decided to change the fuse in the AC adapter plug to see what would happen and it worked again for about 3 seconds before it stopped again. 

Looking back, the power pack of the charging cable always got quite hot. I also stupidly had the charging settings set to max despite usually having my laptop plugged in. So that probably would affect battery life, but it was still holding a charge. Maybe it caused needless overheating of my adapter?

Another thing I noticed on the past few weeks is the occasional flash for a split second of a white and black pinstripes across my screen.

Would I need to replace the AC charger or change the charge port on the laptop or both? I assume the power pack on the AC adapter is causing the fuse kills?

Thanks in advance for any help

 

181 Views
0 REPLIES 0