Showing results for 
Search instead for 
Did you mean: 

ASUS TUF A15 2023 (FA507NV) WHEA Warnings (Event ID 17) when gaming

Level 10

I recently bought a new laptop Asus TUF A15 that comes with Amd 7735HS and RTX 4060. Upon running any game I start getting a large number of WHEA warning that points to a PCI Express Root Port hardware error with the bus location of the Nvidia card (0x0:0x1:0x1). Initially thought I had a defective unit so I ordered a replacement and the new unit has the exact same issue.

I have done all sorts of troubleshooting and turns out the only driver version that does not produce any warning is 528.01, anything newer especially with the 531.x branch, I get 20 to 50 warnings in just a couple of minutes of gaming. This has been tested on Returnal, Resident Evil 4, and Hogwarts legacy.

Steps taken to troubleshoot:

Offline OOBE with no updates = no WHEA warnings

Updated only BIOS & GPU drivers to the latest version = WHEA warnings appear

Complete update done on Windows and all drivers = WHEA warnings appear

Ran DDU and reinstalled driver version 531.68 = WHEA warnings appear

GPU (~70c) and CPU (~80c-90c) temperature look normal with no throttling.

I tried doing some research to see if someone faced a similar issue but it seems this card is fairly new and not many complaints are out there yet

Would appreciate it if someone can provide me with a solution to solve this as I desperately need help and I am tired of all this troubleshooting


Level 12

here they report a similar problem, where it is written that it was fixed by updating in the BIOS.

In case you have already updated the BIOS, then you should try reverting it to an earlier version.


Unfortunately, it seems newer ASUS models do not allow you to downgrade to older BIOS version (current version is 306).

Nevertheless, I was able to reproduce the issue on a display unit in the store which had an older version (304) and the WHEA warnings also appears during gameplay.

Level 12

There are several causes that lead to Whea errors, but it usually depends on excessive undervoltage on the CPU.

You should go into the bios and disable the function
PCIe power state management.
This step usually solves the problem.

If it does not solve the problem, try disabling ASPM as well
and manually setting PCIe for the GPU to Gen4 instead of leaving it on Auto.
Possibly also disable PICe Link power state management in the Windows power plan.

Asus does not expose any of the settings you mentioned in a laptop bios otherwise that would have been the first place where I would troubleshoot

Also I tried turning off PCIe link power state in the Windows power plan however WHEA warning still appear

Level 12

unfortunately the bios are different from each other
you should look for something like this



Level 12



As mentioned, this is a laptop bios only basic options are there, all these tabs and settings you are showing are not available.

Level 12

I gave an example to show you where you might find them. If these options are nowhere to be found in your bios, then you should know that some people have solved WHEA problems
- by resetting the original bios settings with f/5
- others have solved by reinstalling the bios.
- others by repairing the system, opening the promp as administrator and giving these commands:
sfc /scannow
DISM /Online /Cleanup-Image /RestoreHealth
- others have solved by slightly increasing the CPU voltage, i.e., the opposite of what is explained in this link.

Or you can contact Asus support, who presumably know specifically about that type of problem on that specific PC.

thanks for the suggestions

I honestly exhausted all options that is why I posted in this forum to see if there is another way to troubleshoot

I already opened a support ticket with Asus and Nvidia as well, however, I doubt they will provide a solution before my return window is over

This laptop will most probably be going back and I will be waiting a couple of months until there is more availability of this CPU and GPU combination from other brands