Showing results for 
Search instead for 
Did you mean: 

Armoury Crate Audio Settings Don't Work!

Level 8

2022 Asus Tuf Gaming F15 (FX507ZM)

Recently I believe there was an update and that messed up everything. So I had to uninstall using the Armoury Crate Uninstall Tool, then reinstall Armoury Crate. Seriously though everything is working except the audio settings. I have uninstalled and reinstalled multiple times! I don't think Armoury Crate installed the AI Noise Cancelation Audio Software very well or I don't know where the exe is in a folder to somehow force run it maybe? Anyways ASUS needs to fix this! This is a huge bug! The audio settings just show up blank when clicking on the audio tab and Armoury Crate just freezes up like a crash and I have to use task manager to simply close the settings don't work.png


Level 7

I have the same issue, descriptively the same.

Level 7

Same here on Asus X16 GV601R newly bought.

Tried the uninstall tool -> install full package and it does not install correctly

Tried then uninstall tool -> Aura & armoury crate install. It installs but whenever i go to the sound tab it freezes. I cannot get the mic to work in apps.

I am stuck now please  repair this soon.

Level 7

Even i Have The issue Asus Fix This Immediately. It has Become a Pain to Fix it 

Level 7

Same issue. Clicking on audio options crashes Armory Crate. Please update.

Level 10

I have the same issue, selecting Audio in Armoury Crate freezes the application, I think this only started to happen only after the audio driver update done through Windows Update

An alternative way to change the audio settings is through Realtek Audio Console

But you cannot change the (AI) settings in the Realtek Audio Console. That is quite a useless app.

sure you can, refer to the below screenshot


Ah I see! I don't have these settings, never had, stock ROG Flow X13 drivers. The Microphone Array is pathatic, doesn't work at all.

Only way to access the AI Noise Reduction MIC + Speakers is via the Armoury Crate Audio tab. This Realtek app is pretty useless on a Flow X13.
Worst thing is: the mic is not working. Need to fiddle with the Armoury Crate Audio settings for that, which doesn't work. So for now, I cannot use Teams/ Discord etcetera.


Level 7

I have the exat same issue and can't use the AI noise cancelling which turns the microphone useless. Can't believe it's taking this long to repair.