cancel
Showing results for 
Search instead for 
Did you mean: 

TUF Gaming VG34VQL1B artifacts / shimmering

Radical_53
Level 9
Hi,

I've been having a blast with this monitor. Speed, color reproduction, even it's limited HDR capabilities -> perfect upgrade.

I do have two issues though:
1. It doesn't seem to send any form of HDR certificate, which could be the reason I have to switch HDR on and off manually all the time.
2. Blue/violet artifacts/shimmering in dark spaces at higher speeds.

The 2nd is something I didn't notice at first, but now I can't seem to look past it anymore. It's almost like chromatic abberations in photos?
I've been using VA monitors for the past years and I've never experienced something like this.
I tried to play around with the OD setting a little but it didn't really change much (that I'd notice).

Any advice?
6,161 Views
9 REPLIES 9

RedSector73
Level 12
There is a WHQL driver & ASUS DisplayWidget Lite, have you tried these ?
https://www.asus.com/Displays-Desktops/Monitors/TUF-Gaming/TUF-Gaming-VG34VQL1B/HelpDesk_Download/

Hi,

thanks. Yes I do have those drivers installed. I've tried different things, like enabling and disabling G-Sync/FreeSync/VRR, various overdrive settings, 8-bit and 10-bit color depth.

PS: I have no idea I should make a video or something, but even scrolling this site up & down quickly, white letters on black background, will make the letters turn into "rainbow" while they're moving. Letters stay clearly visible, they're just not white anymore.

I changed the cable for a new DP 1.4 version, the problem persisted.

Only turning off OD completely when HDR is enabled will get me rid of the artifacts. Hopefully there'll be a firmware update to address the issue.

Hello,

Up of this tread.

I have V13 firmware on my screen asus VG34VQL1B , what is the latest version ? How we can get it ?
Thank you.

V13? Interesting. So far (mine included) all the screens I knew had V12.

Well, I just received my replacement screen and it comes with firmware V013! But now I feel like an idiot as it doesn't seem to allow me to turn on HDR.
With the screen completely reset, I never had a setting that prevented me using HDR?

Second replacement arrived today, firmware V017. Still no HDR, still greyed out.