cancel
Showing results for 
Search instead for 
Did you mean: 
MasterC
Community Admin
Community Admin

When assigning or reassigning keys, sometimes it's necessary to utilize a virtual keyboard, especially on TKL (tenkeyless) or ultra compact keyboards such as the ROG Azoth or Falchion series.

When you want to swap keys around or assign any keys your keyboard doesn't have physical keys for (such as numpad keys), the latest Armoury Crate update V5.8.6.0 makes it easy to map different keys to the keyboard or mouse.

1. First, select the key or mouse button you want to reassign.

image.png

 

2. Choose Keyboard function

MasterC_1-1709015386670.png

 

3.  Click on the Virtual keyboard icon

MasterC_2-1709015447840.png

 

4. Assign the new key function, and you're done. 

MasterC_1-1708923291660.png

 

If you made a mess of things, don't worry, just click on Reset and start over. 

MasterC_3-1709015607540.png

 

6 Comments
tg_grunwald
Level 7

Hi!

I have a ROG CHAKRAM X mouse, and it's working (2.4ghz) fine with my Desktop, all buttons and joystick remaped works flawleslly with my scenario profiles, no problems at all.

Recently I bought a TUF GAMING A15 Laptop and trying to use Chakram on bluetooth mode.
I've remaped the buttons and sync with internal memory, but the buttons I remaped with a KEYBOARD FUNCTION don't work, no matter what keyboard shortcut I assign to it. If I map the buttons or joystick with multimedia or any other function, it works fine.
I tried clean uninstall tool of Asus armoury crate and re-installed, no success.

Please, how can I fix this, I bought this mouse cause of number of buttons and now I cant get it to work.
Everything is up to date.

 

MasterC
Community Admin
Community Admin

What keyboard functions are you trying to assign to the mouse buttons? I tried a couple and they work as expected on my end. 

MasterC_0-1709288497155.png
If you are trying to use complex functions or if a delay between keypresses is required, then record a macro.

 

tg_grunwald
Level 7

Thans for reply, the keyboard functions are not complex, it's the same I use for my desktop and works fine.
I can map the function but it dont work when I use it.
For example, I assigned CTRL+T to scrollwheel, and I have some scenarios linked to applications, with different shortcuts (CTRL+Q, CTRL+O, etc).
Everything is working just fine on my desktop. 

I did the same mapping at my new laptop, and the shortcuts are mapped, but dont get to work, looks like it's some conflict with laptop and mouse at armoury crate.
Heres a screenshot example of my desktop.

tg_grunwald_0-1709288715035.png

tg_grunwald_1-1709288814909.png

 

 

 

 

tg_grunwald
Level 7

Looks like Armoury Crate is not installing all drivers of Chakram X correctly.
Here's how device manager looks at my desktop (mouse working) and at my new laptop (mouse not working)
DESKTOP

tg_grunwald_0-1709322527283.png

LAPTOP

tg_grunwald_1-1709322564905.png

 

 

MasterC
Community Admin
Community Admin

Tried uninstalling Armoury Crate from here already?

MasterC_0-1709529682766.png

 

tg_grunwald
Level 7

Yes, 3 uninstalls, even with official uninstaller.

I just found that the problem was at armoury crate not install drivers of the mouse.
I solved it, by copying my driver repository from my PC to Laptop, then install the drivers manually.