Showing results for 
Search instead for 
Did you mean: 


Level 7

I have been using Asus Zephyrus M GU502GV. Yesterday i just bought a WD Blue SN550 M.2 SSD NVMe 500GB.
After this SDD is installed in slot M.2, then I power on this laptop, but stuck on the Asus logo screen. none of the F1-F12-DEL-ESC keys work. except the power button to turn off the laptop. (sv nvme must be removed for my laptop to boot).
After that incident, I did a search on the internet, and found quite a number of cases happened to other people. they have updated the bios, settings related to m.2 / nvme in the bios, but it didn't solve the problem. so they must to remove SSD or replace the SSD with specific brand / type to make their tuf laptop could boot again.

Things I have tried:
Pulled out my Intel 660P and just plug the WD SN550, the boot process stuck at Asus logo, no BIOS.
Put back my Intel 660P and pull out the WD SN550 the system is boot normally again.
Update to the latest BIOS (ver 309), still no luck.
Enter BIOS, disable Fastboot, Secure Boot etc and then plug back the WD SN550, still no luck.

Question: what causes this to happen? what ways can be done to fix this problem?
Thank you very much in advance for the answers and support!

Level 7
No one experienced similar issues? 😞

No one experienced similar issues?

Level 8
Before installing the SN550 and after booting into BIOS, what mode is enabled under SATA Management? If INTEL RST PREMIUM is enabled, disable Intel Optane within Windows. Restart into BIOS, and then switch the SATA mode to AHCI. If you switch from INTEL RST PREMIUM to AHCI before disabling Intel Optane, there’s a chance that your OS will not boot successfully. After changing SATA mode to AHCI, save the BIOS settings, and then turn off the computer. Install the WD SN550 and power on the computer. Are you able to boot into BIOS?

Another method you can try is booting from the Windows 10 installation media via USB flash drive and see if DISKPART is able to detect the SN550. If you haven't created a Windows 10 installation media, you can do so here:

If the USB flash drive isn’t detected in BIOS, verify that Legacy USB and USB Mass Storage Support are enabled.

Plug in the USB flash drive containing the Windows 10 installation media. Boot into Windows. Click Start--> Settings--> Update & Security--> Recovery--> Restart Now (Under Advanced Startup). Click on the USB flash drive containing the Windows 10 installation media.

*Alternatively, you can boot into the Windows 10 installation media by choosing the USB flash drive as the first boot device, after powering on the computer.

Once the Windows installation Media finishes loading, click "Repair this computer" and then click "Command Prompt".

Type DISKPART, then press Enter.

Type LIST DISK, then Enter.

Do you see the SN550 listed? If you do, type SELECT DISK #, replacing pound with the number assigned to the SN550 (ex. SELECT DISK 1).

Type clean, then Enter.

Type convert GPT, then Enter.

Type exit, then Enter.

Restart the computer.

If you do not see the SN550 listed, perhaps you can try restoring the default settings in BIOS. Switch the SATA mode from INTEL RST PREMIUM to AHCI, if needed. Save BIOS settings and then power off the computer. Remove the Intel 660P and leave in the SN550 (the SN550 should be the only drive installed). Try booting from the Windows 10 installation media again and repeat the above steps for DISKPART. If the SN550 is still not detected, then perhaps the drive might be faulty or unsupported. If you have another computer that supports M.2 drives, see if that computer is able to detect the SN550.

I’ve been using the WD SN750 as a secondary drive for about a year and a half. The only issue I’ve experienced was the inconvenience of setting it up as a boot drive. The WD SSD would not boot successfully if the SATA mode in BIOS is set to INTEL RST PREMIUM. If I wanted to boot from the WD SSD, I would have to change the SATA mode from INTEL RST PREMIUM to AHCI in BIOS. I decided to use the WD SSD as a storage device since I did not want to lose the benefits of Intel Optane Technology.

Good luck!

Level 7

If you are using them in AHCI mode, i think your SSD's firmware is conflict with your mainboard, please try another SSD. I have the same issue and since my SSD and BIOS version is the latest so i change to another SSD and it worked.

Here are my cases:

- Installed the SSD and run in AHCI mode: stuck on boot (can't press F2 to go to BIOS setting, have to remove the SSD to boot again)

- Removed the SSD and run in AHCI mode: boot ok

- Installed the SSD and run in RST/RAID mode: book ok

You should try:

1. Update BIOS version

2. Update SSD firmware

3. If you don't need to use AHCI mode, change it to RST mode

4. Buy another SSD (in my case, it worked)