cancel
Showing results for 
Search instead for 
Did you mean: 

Zenbook Duo 16" (2023) / AMD 9-7945 / 4090 - Screen Brightness

dedomena
Level 8

Machine is brand new.

Everything was working; I installed all available updates, and now screen brightness for the primary display will not change.  Fn-F7/F8 trigger the 'brightness adjustment' image to appear, and the slider moves to the bottom or top, but screen brightness does not actually change.

 

I have uninstalled / reinstalled nvidia drivers, asus control driver, and re-installed the from-factory nvidia driver.  Also changed power modes / restarted many times, and I cannot pinpoint exactly when this started, but I no longer have any brightness control on the primary panel.  Windows control also inoperable (same behavior; the on-screen brightness slider moves around but brightness never actually changes).

Any ideas / recommendations?

 

Thanks in advance.

413 Views
10 REPLIES 10

dedomena
Level 8

I have discovered if I enable HDR, the brightness will change.  Disabling HDR immediately disables ability to control brightness, however. 

mbze430
Level 9

Having the same EXACT symptoms.  If I enable HDR, the FN+F7/F8 works.  But in SDR it doesn't.  AND using the windows brightness control doesn't work either...

mbze430
Level 9

Also, I already reset Windows back to factory and also loaded BIOS default settings and still the same.  I am short from installing Windows 11 from fresh media.

So it is either a Windows Update of some sort, because I think a factory reset keeps all of windows update? or some kind of drivers.

 

 

izy
Level 11

something to note brightness control does work in ultimate mode and sdr

dedomena
Level 8

I also encountered random reboots (which were actually IRQL bsod's, just so fast the bsod never displayed; confirmed via wer / minidumps) -- in an attempt to resolve that I uninstalled the amd adrenaline software. 

I *think* that might have solved the brightness control issue, as I now have brightness control.

However, it did not help system stability.  Did a complete 'fresh' / 'clean' Win 11 install... *sigh* ; I have learned that the uninvited software comes in the back door automatically as MS & OEM Asus have apparently arranged it as such.  Uninstalled adrenaline again.  Then one more time from the 'system -> apps', as it came back after uninstalling from control panel.  

This also did not help stability.  However, I fired up services.msc and was *shocked*, ___SHOCKED___, at how many services are installed and running by default.  Between AMD / Asus / ROG / Armory Crate, I think I counted close to 20? (or more?) . 

I disabled all of them.

With some trial and error I then re-enabled what *might* be the minimum services, to regain screenxpert and Fn-hotkey controls (including brightness) -- and this seemed to have a HUGELY positive impact on system stability / reliability.  I've only had one bsod since doing so, and it was not the IRQL related, but power related (about 99% sure modern standby issue; modern standby suuuuucks; give us back suspend-to-ram, for all Win clients - modern standby is the bane of my corporate environment on non-Asus machines).

OK, so the reason why you probably read this far, the services that are enabled (all other amd / asus / rog services disabled) -- NOTE, this will make armory crate inoperative.  So set it the way you want prior.  If you want some control over boost clocks, do the registry edit to add the 'processor boost control' dropdown to the control panel power profile advanced settings...

Enabled services (and chime in if these can be disabled, or if there are others I should really enable and why?):

Asus App Service

Asus Optimization

Asus ScreenXpert

Asus ScreenXpert Host Service

Asus Update Service

Asus Numpad Service (havent used numpad yet... might try disabling?)

Prior to giving adrenaline the boot, and disabling all the above services, the machine failed to make it through a single PCMark 10 run.  After, I have been able to do 8 runs back to back in a single session without issue, and have not had a random reboot / bsod while interactively using the machine.

Hope this helps someone else...

extra bonus rant, feel free to ignore:

Oh, and for the record, I think armory crate might possibly be a good candidate for world's worst application.  I don't know anyone that likes it, and it literally took me like 20 'fresh eye attempts' before i finally figured out how to get to the 1% of the program that does useful stuff; fan curve control, cpu & gpu power tweaking and GPU OC.  I'm a veteran IT guy going back multiple decades, and use Linux / BSD and other weird software all the time, and I literally spent over an hour and a half in the ****** thing, cumulatively, over a week, before I stumbled onto that 1%.  Honestly, horrible design.  Maybe I had continual brain farts for the week, being enraged at the bsod's, but Asus, please -- look at the open source alternatives that exist and take note.  Useful, straightforward, and clean.  *sigh* ok, I'll get off my soapbox now..

 

mbze430
Level 9

Thanks for taking the time to test it out.

I took it a little further and found out it's the actual Video drivers for the 610M but the Adrenaline software is still available for whatever usage one might have.

If you roll back on the 610M drivers the brightness control comes back.  

As for Amoury Crate, it is a hog.  I recommend you Google G-Helper. 

Huge fan of G-Helper. 

If you want to stop more unnecessary stuff from auto-starting (example being armory service that persists after uninstall of the crate) check task schedulers asus folder...

Thank you!

izy
Level 11

did all this on mine like 1 day into owning laptop

do note you will lose the software functionality of one of the screen expert apps
aka the one that gives a 2nd keyboardish panel for controlling photoshop /premiere etc

also if you use ghelper the front page of the git links to armoury crate uninstaller, or if you open the folder containing the armoury crate service exe you can rename the file after turning it off and it will never start again

you also lose the functionality to disable touch screen on the 2nd display as thats only in armoury crate, i tried figuring out what causes it to work so the dev could add it to ghelper but no idea

reddot911
Level 9

Check in guides for brightness. If doesnt help ask them.

https://m.facebook.com/groups/asusrogduogroup/?ref=share&mibextid=NSMWBT