Showing results for 
Search instead for 
Did you mean: 

USB Type-C Doesn't Power Devices (Zephyrus GU502.DU)

Level 7
I've been having this weird issue with my Asus Zephyrus GU502.DU on bios 208 that has carried over between windows 10 installs and on two physically different SSDs. It had a type-c USB port that is (I think) managed and fed data by the Nvidia chip, or is at least connected in some way as it functions as a display output just fine. For devices with external power like drive docks and phones it connects and transfers data totally fine.

What doesn't work is the usb-c ssd (definitely not thunderbolt, this is an AMD laptop and this drive works with typeA-C as well as type-c-c on my desktop) that doesn't even show up in device manager in windows let alone receive power and light its blue status light. I think it's something to do with either a sense pin that was never 100% soldered onto the board, or the PC doesn't know how to wake this port without external power to a connected device (super weird). Can anyone help me out here?

Same deal with a usb-c keyboard that lights up when connected via type-a-c on the same laptop, but not type-c-c. The cable is a good cable that on another, externally powered data dock, pulls hundreds of megs per second read and write, and pulls hundreds of megs per second on this ssd on my desktop. I've also tried a long apple type-c to no avail. I haven't tried it in a while but back when first testing this I remember it charged a Samsung over type-c just fine so I don't think it's inadequate power delivery.

Level 7
I wonder if this at all related to my issue. Here's what I found.

On a clean new install of Windows 10 Version 1909, I noticed an Unknown Device (ACPI 3515) that was associated with a USB Type C Power. I saw this in the Device Manager. After a bit of research, I found that the device on the the MB is an Intel controller powered by a Texas Instruments chip, and you need a driver to "enable" the power features for USB Type C. What I came up with is a driver called TPS65988 integrated.

I found that driver in the Microsoft Catalog, here:

I couldn't help noticing that this might be Windows 10 version related since 1803.

Maybe this has nothing at all to do with your issues.

Mixer wrote:
...What I came up with is a driver called TPS65988 integrated...

Thanks Mixer, I'll take a look and see what I find. This is a real break!

Mixer wrote:
...What I came up with is a driver called TPS65988 integrated...

In short, I got nowhere with this, and am back to suspecting it's something to do with NVidia drivers. There are two.. maybe three devices that lead me to this.

NVVHCI Enumerator from Nvidia where people talk about it controlling usb-c ports, but the linked thread isn't for an x86 system so I may be wrong here.

And again I'm going to try chasing after what this device does "NVIDIA USB Type-C Port Policy Controller" because it just seems weird to me.

Does anyone know if it's normal for this this "AMD USB 3.10 eXtensible Host Controller - 1.10 (Microsoft)" device to have a Microsoft driver instead of an AMD driver? I've got two of those "devices" but only one USB-C port. (Also only one port capable of 10Gbps, which I think is what 3.10 refers to (the laptop shell also has a very, very small 10 next to the port, which no other port has).

To get even more confusing, there's a Microsoft driver for an NVidia USB 3.10 device, "NVIDIA USB 3.10 eXtensible Host Controller - 1.10 (Microsoft)".