cancel
Showing results for 
Search instead for 
Did you mean: 

My GPU is stuck at extreme power saving mode in armoury crate

Infernus822
Level 7

My dedicated GPU for some reason has stopped doing its job and it doesn't work. In task manager, it's always at 0% utilization and all the graphics work is being done by my integrated GPU. The name of my GPU has also disappeared from the top, in armoury crate. I have tried enabling and disabling the GPU in display adapters, reinstalling drivers, and resetting my laptop,  however, I haven't seen any improvement. Furthermore, I had my laptop checked for any hardware defects and they said that everything looked fine. Please help me resolve this issue.

Infernus822_0-1717743217188.png

 

889 Views
7 REPLIES 7

Keogmar
Level 7

I just fixed mine. It also wouldn't let me install an update on my Geforce driver. Kept saying not compatible with Windows all fixed and installed.

1. Go to Amoury Crate.

2. Change performance to Windows.

3. Unplug laptop and plug it back in. Started recognising gpu again.

4. Go back to turbo and it let me update the driver.

Hope this helps! 🤞

Sorry dude, I tried but it didn't work 😞 It might be cuz our laptop isn't the same. I have AMD graphics and yours is NVIDIA which might work differently. But I do appreciate your help! Thank you!

Ok so an update guys, i installed g-helper and for some reason my game is working normal all of a sudden which is good but I'm still not sure if it has completely fixed all my GPU issues....will keep on updating.

MatthiasC208
Level 7

Hey Infernus,

I think it is a problem with an update causing this.
Mutiple people already posted on the forums having the same problem, as do i.

After the latest update my armoury crate say's the GPU is in power saving mode, but on my adrenaline software i see it running.

 

Keep me updated if you have any changes!

 

So I am using this software called G-helper....it has shown me some improvements but my performance is not as good as it was. Maybe it'll fix your problem. Just google G-helper and it should take you to github where you can download it. Hope that works!

Sick_Man
Level 7

I had the same problem, i had to unistall everything amd related with amdcleanuputility then download and install AMD_Chipset_DriverOnly_ROG_AMD_J_V1.2.0.117_21762 and the Graphic_DriverOnly_ROG_AMD_J_V27.20.22001.24003_26522 only then armoury crate could recognize my graphics card, but if i install amd adrenaline edition it desapears again, i belive we have the same laptop, so that should help.
I still have issus with armoury crate since i'm not able to change the gpu mode, if you know how to fix that let me know.

Riviar
Level 7

Has anybody managed to find some definite resolution of the problem? I have the same issue. Tried to reset the system, reinstall armoury crate and drivers separately, tried it with drivers listed on rog website, then with and without adrenaline software (even though rog website doesn't seem to acknowledge its existence). It's still broken after all that.

The GPU evidently does somehow work, but armoury crate doesn't recognize it and it behaves strange - since the issues started I am experiencing random crashes, stuttering and frame drops at random when gaming. Since I can't reliably monitor what it is doing, I don't know if it is even safe to use the laptop for any stressful work. It might not properly react to temperatures and such and I wouldn't know.

I don't want to use 3rd party while the laptop is still on warranty, because I expect the support would use this as argument to void the warranty instantly. Not that they were ever of any real help, though, and this piece of junk is having some problems all the time...