Showing results for 
Search instead for 
Did you mean: 

My Adventure Upgrading GA401QM-211 SSD Drive

Level 7

So, I own a G14 that came stock with a 1 TB Samsung SSD that was working great, but I was rapidly running out of space, and I decided to see about moving to a larger size drive.  I did my research.  I'd need an NVMe 2280 SSD, but I didn't know what generation would work, but with backward compatibility, I guessed I'd go for the middle of the pack with a Gen 4 SSD.

Great!  I now knew what type I needed, and I chose to not go overboard, aka spend a ton of money, and settled on a 2 TB drive.  Then did some more research balancing reviews, cost, and performance and settled on a Western Digital Black 2 TB SSD that was $99 - perfect!

Next step, figure out how to 'clone' my OS and files on to the new SSD.  To do that I'd need either a duplicator device or an enclosure -- the enclosure was cheaper by far (although not as easy or reliable), and I found a decent, inexpensive model for around $100.  I figured I could repurpose the enclosure as an external drive with the Samsung SSD or a larger SSD later, so money well spent, right?

Before I actually began pulling the trigger on purchases, I still had an outstanding question about heat sinks -- should I? Could I?  More research was needed, but I found a veritable black hole -- no info on what size might fit in the G14.  The YouTube videos all showed people just ripping off the original, thin metal, heat sink from the old SSD for reuse -- talk about an inelegant solution!  (As it turned out, my ASUS lappy only had about a one-inch thermal pad on the 'bottom' of the Samsung SSD, and it stayed stuck where it was when I removed the SSD!)  In the end, I bought the WD SSD without a heat sink, saving some $$$.  But, back to my narrative.  I decided to see what ASUS support had to say about the issue -- in fact, I decided to see if there was an authorized service provider that I could use to actually perform the upgrade, removing all risks and quashing the need for learning the intricacies myself!

When I contacted ASUS support, I was told 3 important things: one, I'd have to ship my machine out for service, two, upgrading to a different brand from the installed SSD wasn't supported, and three, going above 1 TB wasn't supported, as these last two things might damage the machine!  Now, I've been around for a bit, and the days where using large drives was problematic due to addressing, power consumption, and proprietary tech issues are no more, and going from a 1 terabyte to a 2 terabyte SSD, with the correct form factor but different brand, wasn't going to melt my laptop.  Here, ASUS, pull my other finger...  Worst case scenario, I'd spend $$ and end up with a 2 TB external SSD, so I decided to plow forward without OEM blessing.

D-day arrived (D = drive), and I popped the new WD SSD into the enclosure, used the free WD drive cloning software, copied the old SSD to the new one.  Cracked the case and discovered, as many people had stated online, the SSD set screw holding the existing storage in place was a cousin of Mornir, but after some colorful language, a lot of effort and patience (luck), I got it lose without stripping it -- BIG win!  Installed the new SSD and rebooted...

First reboot, no issue, but Windows (11 Home) said hardware had changed, and I'd need to restart -- which I did... Blue screen of death! There was a problem with the MBR (master boot record).  I restarted, initialized the boot options, dropped to DOS (yes DOS is still there), ran bootrec \fixmbr from a command prompt, restarted again, and success!

When I tried to look at the old SSD, via the USB enclosure, I discovered that it was encrypted by Bitlocker -- even though I had never set it up to be encrypted!  In fact, I would have NEVER done so, because of a past disaster where I lost access to a hard drive forever when I lost the encryption key.  In the end, I found the recovery key via my Outlook account, and I was able to view the drive contents, but I had to upgrade my OS to Windows 11 Pro to gain access to Bitlocker to unencrypt the drive -- believe me, I tried every other way to no avail.

Guys, it can be done, but it has some kinks due to the BIOS and OS using secret hardware ids, Microsoft butt-holery, and ASUS being an OEM that acts like Daffy Duck with a big diamond.  Feel free to comment, belittle or praise my efforts, or tell me how I could done the whole thing for 5 bucks!  I'll update this post if my G14 melts...


Level 10

All I can say is that you got away easy. On devices that come with two SSDs, ASUS has the tendency of running them in AMD RAID 0 by default. Good luck cloning that with any commonly used tools. Nothing I found could even read the partition table off the fake raid array.

Other than that the enclosure should have been cheaper than 100 bucks. I think you confused it with the SSD price (99 bucks). Though PCIe4 enclosures are not common, usually you get a PCIe3 enclosure for 30-60 bucks. Getting an enclosure so you can keep using the old drive as an external drive is the kind of thinking I can commend.

ASUS support saying they do not support non-original SSD installs I do understand, they are supposed to support the shipped configuration and thus cannot guarantee proper functionality with custom changes. It is also why when sending the device for warranty repairs you should have it in the original configuration, otherwise they can just say ruling out that the cause of the issue is the custom change is not part of their coverage. Their excuse for refusing the install was not reasonable though, that I must agree with you on. Fortunately replacing user-replaceable parts does not void warranty (at least in most civilized countries).