Showing results for 
Search instead for 
Did you mean: 

M15 ROG key not working, in Windows 11

Level 8
I was wondering if anybody else has encountered this problem after a recent Armoury Crate update. One day the very handy ROG key just stopped working. The strangest thing is that the key still works if you have Armoury Crate already open but minimised: pressing the key just switches to the app. It does seem to actually register the key since, if you disable it, a notification telling you that it is disabled pops up. The only thing it refuses to do is to open AC normally when the key is enabled.

I have already tried uninstalling then reinstalling using the Armoury Crate installer from the driver page.

Any help on this rather aggravating petty problem would be greatly appreciated.

Level 7

I have this problem in my Zephyrus G14, but only when I'm signed in with my local account. When I sign in with the admin account, the rog key works fine. Also, tried uninstalling and reinstalling the armoury crate.