Showing results for 
Search instead for 
Did you mean: 

GU501GM Laptop screen briefly turns off when connect/remove power cord - [solved]

Level 7
I have no idea what is causing this truly bizarre problem. Whenever I connect or disconnect my power cable for my brand-new laptop, the screen briefly turns off (2-4 seconds). Its really annoying and I would like to know what is causing it, or how to fix it... if it is fixable at all. I haven't seen any other reports of this problem across any forums I know, yet it seems the display model at Best Buy has the same issue mine does, so this is a right-out-of-the-box problem and not something I did when setting up. It doesn't seem like a screen malfunction (no tearing or distortion or flickering), it looks more like the way the screen turns off briefly when I disable one of my GPUs or change the screen resolution or whatever. My best guess might be that it is using the built-in Intel GPU when on battery and the GTX 1060 when plugged in, and the blackscreen is a result of switching between them, but I'm not sure how I might test that theory. I upgraded from an ASUS ROG GL551JW from 2015, which didn't have this quirk.

I did contact an ASUS technician over the online chat, and he confirmed that this is NOT intended behavior, but he was unable to help. His only suggestion was to update the BIOS, but I'm actually running a newer version than on the official ASUS webpage (which is odd because I don't believe I downloaded a BIOS update, so it was a newer version than on the website right out of the box, but newer is better, right?). I've been going crazy updating every single driver for every single component on my machine, from the keyboard and wifi to the graphics card. I've tried to update each driver through the Device Manager, as well as getting the newest drivers directly from Nvidia/Intel/ASUS websites. AFAIK I'm 100% up to date with the newest versions of everything (except the wireless card, which Intel says has a newer version but whenever I try to install it is just says "this software package cannot be installed on your system". While this is annoying I doubt its the source of the problem.)

Any help or ideas would be greatly appreciated, as well as any reports from anyone else who has this issue, just so I know I'm not going insane here.

Hardware: ASUS ROG GU501GM with no customization, includes Nvidia GTX 1060 card and Intel i7-8750H with UHD 630 graphics

Software: Windows 10, newest version


Level 7
Try update all drivers, windows update, and updates from Asus for GU501. It might be the solution because I don't experience it anymore

Thanks to Best Buy GeekSquad for suggesting I take a closer look at the Intel Graphics settings, and this post for giving me the clues I needed:

Basically the problem was in the Intel UHD Graphics Control Panel (not the Windows Control Panel). To fix it, I had to go to Power > On Battery > Global Settings > Display Refresh Rate Switching, and set it to Disable. I guess the Intel graphics chip has a poorly-documented "feature" that lowers the screen refresh rate from 120Hz to 60Hz when running on battery, and this shift requires the screen to restart.

ASUS technical support was unable to figure it out after multiple phone/chat sessions, but the Best Buy guy was able to point me at a solution before I even finished describing the problem 😄 Screw you ASUS support, you're nothing but a waste of time 😄