Showing results for 
Search instead for 
Did you mean: 

GM501GS headset microphone not working

Level 7

When I bought a new ROG Zephyrus GM501GS (Win 10 Pro) laptop in Jan 2020, plug-in headset mics would not work. It has a 3.5mm jack for headsets (speaker+mic). I ended updating drivers and toggling settings until finally the headset mic worked (I think it was using a generic realtek driver that did the trick). Unfortunately that caused the on-board speakers to have terrible sound quality; it sounded like an old-time radio where you could barely understand dialogue because of the scratchy noise. So I basically didn't want to deal with it and ended up just using earbud/mic combo for 9+ months.

However, recently I decided to try to fix the speakers again, because shouldn't an expensive laptop be expected to work? Anyway, I found an ASUS article and followed the instructions and updated the BIOS from the product page to BIOS315 and then reinstalled the latest sound drivers (6.0.8746.1). That fixed the on-board speaker scratchy sound but broke the plug-in mic. I restarted and it seemed for like 1 day that the mic was working... but I'm not entirely sure it actually was, because now it's totally not working. If I turn on zoom and do the audio test and hold the plug-in mic next to my mouth and yell, I can hear like the first syllable of the word I in the playback. It's really bizarre...

Does anyone have any idea of how to fix this? I've basically tried all the sound/privacy setting changes in the top few youtubes/fix-it articles and nothing has worked...