Showing results for 
Search instead for 
Did you mean: 

GA502DU - No performing well

Level 7
Hi All.

Im new to ASUS. I love this new laptop. Partiucularly the Vega graphics run AUTOCAD LT much better than the Nvidia card does (I appreciate its not intended for CAD tho).

however, im having some issues with the laptop. Ive formatted now 4 times with differing ways of installing drivers, clean installs. Have the my Asus, ammo crate installed etc.

Basically it will not run any games very well. I can run battlefield 1 in nvidia recommended settings of mostly high to ultra. But the laptop keeps stuttering every 15-20 seconds, for around 1- 2 seconds at a time. Its unplayable. The sound also stutters / stretches.

Tried in low res mode as thought maybe too hot. Still the same problem.

Ive also noticed intermideate pauses on the mouse pointed during normal use. There's no reported issues in windows etc and no driver errors.

Any ideas appreciated.

Level 7
hi did you ever sort this?

my new laptop has the exact same issue

Level 7
Just check the previous post, you need to repaste it, Asus factory use the worse thermal paste know to human kind. They use a ungodly amount , get better quality paste and use 05mm thermal pad on the vrm .

Thanks in advance for any help provided.


I recently bought Zephyrus G GU502DU_GA502DU. The BIOS is on GU502DU.302
After a week when I tried playing GTA V, my laptop had BSoD. After powering up, I started having issue with my NVIDIA. Below is the DxDiag report. I did clean uninstall and tried reinstalling every version but my device manger shows code 43 error. Please review on my issue and let me know with any solution that could resolve.

xDiag Notes
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Display Tab 3: There is a problem with NVIDIA GeForce GTX 1660 Ti with Max-Q Design device. For more information, search for 'graphics device driver error code 43'
Sound Tab 1: No problems found.
Input Tab: No problems found.

Card name: NVIDIA GeForce GTX 1660 Ti with Max-Q Design
Manufacturer: NVIDIA
Chip type: Unknown
DAC type: Unknown
Device Type: n/a
Device Key: Enum\PCI\VEN_10DE&DEV_2191&SUBSYS_18D11043&REV_A1
Device Problem Code: 0000002B [CM_PROB_FAILED_POST_START]
Driver Problem Code: Unknown
Display Memory: Unknown
Dedicated Memory: n/a
Shared Memory: n/a
Current Mode: Unknown
HDR Support: Unknown
Display Topology: Unknown
Display Color Space: Unknown
Color Primaries: Unknown
Display Luminance: Unknown
Driver Name: C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_8b75cbed4ebcac62\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_8b75cbed4ebcac62\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_8b75cbed4ebcac62\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_8b75cbed4ebcac62\nvldumdx.dll
Driver File Version: 26.21.0014.4294 (English)
Driver Version:
DDI Version: unknown
Feature Levels: Unknown
Driver Model: Unknown
Graphics Preemption: Unknown
Compute Preemption: Unknown
Miracast: Unknown
Detachable GPU: No
Hybrid Graphics GPU: Unknown
Power P-states: Unknown
Virtualization: Not Supported
Block List: Unknown
Catalog Attributes: Universal:False Declarative:True
Driver Attributes: Final Retail
Driver Date/Size: 4/8/2020 5:45:00 AM, 963816 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: Unknown
Device Identifier: Unknown
Vendor ID: Unknown
Device ID: Unknown
SubSys ID: Unknown
Revision ID: Unknown
Driver Strong Name: oem2.inf:0f066de339a33a0c:Section118:\ven_10de&dev_2191&subsys_18d11043
Rank Of Driver: 00CF0001
Video Accel: Unknown
DXVA2 Modes: Unknown
Deinterlace Caps: n/a
D3D9 Overlay: Unknown
DXVA-HD: Unknown
DDraw Status: Enabled
D3D Status: Not Available
AGP Status: Enabled
MPO MaxPlanes: Unknown
MPO Caps: Unknown
MPO Stretch: Unknown
MPO Media Hints: Unknown
MPO Formats: Unknown
PanelFitter Caps: Unknown
PanelFitter Stretch: Unknown

Thank you

Level 9
Hello gigyalzen,
Please kindly send your device to service center for further examination.
Thank you.

I used to have frequent BSOD on my ASUS GA502DU laptop and I tried all sorts of system tweaks and fixes. People recommended that I update the BIOS to the latest version and I did all that. I eve went to the Windows 10 system registry to do some tweaking. Still, the RAM usage would constantly rise over time and that caused a lot of crashing and BSOD on my unit.

However, back in my early years of being a laptop tech enthusiast I remembered that despite the fact that Windows 10 automatically makes updates on all drivers in a system as best it could, one should ALWAYS download all drivers from the manufacturers still. Also the order of driver installation matters as well.

So, after the BIOS update, I decided to update the Chipset from ASUS website. Now, when I checked my ASUS Armory Crate I am glad to see my RAM getting back down when not busy. Memory leakage must have been caused because of not using the actual ASUS chipset driver for the motherboard. This solved my problem.

Level 8
Hi rippler7 ,

Thank you for sharing your solution with others, and glad that our technical support on the website can solve your problem.