Showing results for 
Search instead for 
Did you mean: 

Faulty Battery? Zephyrus S GX531GW

Level 7
Having some issues with my laptop. Its a ROG Zephyrus S GX531GW running Windows 10 latest version. All drivers and firmware up to date.

I noticed this morning windows showed that the battery was 0% (plugged in). There was no mention of charging. I unplugged from the AC and of course the laptop shut straight off. I also noticed that sounds would not come through the speakers but were fine with a headset plugged into the 3.5mm jack and also my USB-C connected display would not show a connection and plugging a phone into it would not charge or show up as a device.The display was fine when plugged into HDMI.

Steps I took to troubleshoot:

1- Removed and reinstalled battery drivers in Windows
2 - Held power button for 60 seconds to discharge static
3 - Disconnected the battery and retried the above step.

I have now left the battery disconnected and the laptop is running on AC. With the battery disconnected, the speakers are fine audio comes through and the right hand side USB-C will now work when my phone is connected (shows up as a device) however it will not charge it. My USB-C display will still not work. Everything else on the laptop is fine, i can still game, run high CPU applications etc - i just have to leave it plugged into AC and run my monitor via HDMI.

I'm guessing the issue with the right hand side USB-C is related to the battery? I would assume its wired through the battery somehow to allow it to disperse power for charging etc hence why my USB-C - display port cable wont work and phone wont charge.

Is anyone able to provide me some clarity on all of this? I feel like I should replace the battery and all my problems will be solved but its a lot of money to spend especially if it turns out the motherboard is faulty for some odd reason, although given everything else seems fine bar that USB-C port im leaning more towards it being the battery.

Hope you can help 🙂

Level 7
I took the battery in to BatteryWorld today. They tested and confirmed the battery was showing 0 voltage. They advised it was dead and would need to be replaced.

The guy asked me what type of laptop it was from and as soon as I said Zephyrus he chuckled and said he had seen 4 of these in teh past 2 weeks. Seems to be a common problem.

Trying to deal directly with Asus now so I can buy a battery direct but they are telling me they wont send me a battery direct and I would have to return the laptop to there service center in order for them to supply a new battery (right to repair anyone?) .I need the laptop for work and as such am unable to send to a repair centre.

I also haven't been able to source from another supplier. Battery model is C41N1828 (15.44v 60Wh)

If anyone can assist let me know.

Level 9
Hello masonb,
I'm really sorry about this issue.
Please kindly send your device to service center, we are not able to sell or replacement battery separately outside the authorized service center.
Thank you very much.

Hello @masonb

Have you fixed your Zephyrus battery?

Last friday I woke up and my type-c hub wasn't working and my battery is stuck on 59% after using MyASUS feature "Battery Health Charging" on maximum life span, which limits the battery to 60%.

My laptop shut down as soon as I unplug the power cable. Using the System Diagnosis for the battery, it says my Battery has '1 Problem' but don't mention any information at all.

I've just opened a ticket to the support, but as I live in Brazil and the laptop was bought in USA, I think they will dodge from the assistance 😞

@ Blake@ASUS do you work at ASUS? Can you please help me?? I still can'nt believe my 7 months laptop has both usb-a (left), 2.5mm jack, battery and usb-c ports with problem!

Level 8
C41N1828 batteries are on the Bay and elsewhere - of course there is a risk in getting a genuine one. I managed to get a second hand lithium battery for my ZenBook from a PC breaker on the Bay to replace one that wasn't charging properly and 3 years later it is still going well. A chance well taken.

Level 9
May I have you complete model name and Which version of BIOS are you using now?
Please also update the ASUS System Control Interface & My ASUS (new update on Sep 15) and then run the hardware diagnose again.
Thank you.


I wish i had good news for you.

I took my laptop to a service center, they replaced both the battery and motherboard which solved the problem....i was getting a charge again and ~1.5hr battery life.

4 months later however the exact same issue has popped up. The battery no longer charges and the service center will only provide a replacement battery.

This laptop is garbage, barely a laptop with the battery life you get. I'm so disappointed in the product and have made a complaint to ASUS in the hope they will do something about this. Replacing the battery every 3-4 months is just a joke.

Anyone from ASUS want to chime in here. Surely you don' expect us to replace a battery every 3-4 months....hardly a repair option.

Level 7

Hi masonb, could you solve it somehow? I’m just in the same situation as you were years ago. What did you do about this issue?