cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 502 with new Armoury Crate update!

DariusDavedane
Level 9
Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!
32,609 Views
49 REPLIES 49

DryreL wrote:
Hey guys,

I found a solution, thanks to reddit user @ryrydawg

Click here to go reddit post

1) Use Uninstall Tool to completely remove Armory Crate / Restart PC
2) Download ROGLiveService_5.0.8.0.exe and install
3) Disable Windows Store auto update
94592

Good luck!


Unfortunately, this version is way too old, it does support fan profiles/control. Not sure whether it's because laptop is 'too new' or software is old, previous last-working version had this functionality. Also, just like @diegorluna pointed out, turning off updates is not a solution.

Waiting for the update from Asus.

DryreL wrote:
Hey guys,

I found a solution, thanks to reddit user @ryrydawg

Click here to go reddit post

1) Use Uninstall Tool to completely remove Armory Crate / Restart PC
2) Download ROGLiveService_5.0.8.0.exe and install
3) Disable Windows Store auto update
94592

Good luck!


Its been a while!)
Good to see you guys again))

So I lived peacefully at ROGLiveService_5.0.8.0 version, disabled all updates possible:
- autostart
- microsoft store
- task sheduler
- clicking "no" for any updates, when starting armoury crate...

But somehow...today it managed to force update again!
Same freeze on install as before.
And new error 601 after freezed installation of course.

Strange Updates Season 2 started

Wow, Asus rolled out new update recently, now I get 601 error instead of 502. Thanks you Asus, you're doing huge progress and you really cares about all of your customers. Thank you Asus for all what you doing.

P.S. It's been almost a year since I've bought premium laptop. The laptop on which I'm neither able to control coolers (that sounds on idle like vacuum clear) neither to change keyboard lights (looks like fancy rainbow, which is awful). I'm definitely going to stay away from all you "premium" products in the future and I'll encourage everyone to do the same

DryreL
Level 9
I know it's not a proper solution, but atleast you can use the program this way until they fix the real issue on the latest version

It's been 2 days that I can't find an answer why ARMORY does not want to install, telling me that I have lost the Internet connection, (while it tells me nothing since I am connected); so, I just installed AURA without ARMORY. I can do this for my motherboard and power supply, but not for my graphics card, so that's not too much of a problem.
I took the 1.07.79_V2.2 update.
https://www.asus.com/campaign/aura/nafr-ar/download.php

Just wanted to restet my laptop, and have a clean instal, and after new configuration i try to install the armory crate, man i really hate all the asus software.
Rog eye does not work on windows 11, must buy rog eye s
Armory crate can't be installed on a Clean Windows
Rog delta headphones ALWAYS changes the audio settings what is the solution?!

Hello guys. Just happen to go into this problem with my new zephyrus g14(2022), Finished windows installation and it launched ok, then i went to the update within the app and it no longer works. I have tried several methods from this forum and several sites, but still can't get armoury crate to install(error 502). Also tried to install with the full package, but my laptop isn't listed and i cannot advance in the install. Anyone got this problem solved?.
Thanks in advance!!!

P.D: Is possible to download previous versions of the installer from asus?. I cannot find it on the official site.

DBenicio
Level 7

Aqui o problema foi resolvido.

fiz o seguinte:
Formatei o PC, depois de tentar instalar mais uma vez, mesmo assim o erro 502 continuava.

Instalei algumas atualizações do WIndows que estavam pendentes.

desinstalei o APP com o desinstalador fornecido pela ASUS. 

Instalei o pacote Armoury_Crate_Full_Installation_Package e a instalação correu muito bem.

Acredito que o problema estava com alguma atualização do windows causando conflito.
Então formatei o PC atoa kkkk.

Az1m
Level 7

Hi to every one. Found out part of the problem. Installation pack can't just unzip package and then install. It start installation when founds installation file, without waiting till the end of unpacking. Than I start installing manually, partly it started moving. But I stucked in part Peripheral (I think it's part that should find Peripheral devices with ROGLiveService, which can't be run). But now it can change visual and turn on Turbo 😄 but still don't work! Fix **bleep** program!

ThomasHelzle
Level 7

So: Bought an ASUS ROG STRIX Laptop last year during BF:   https://www.amazon.de/dp/B0B7FRC3ZB/ref=pe_27091401_487027711_TE_SCE_dp_1?th=1
Armoury Crate worked just fine at first, then one update to the HAL did not install and nagged me constantly about it.
I ignored it for a while, repeated the update several times but there was no meaningful Error message other than that I should reboot and retry - well, that didn't work the last time, buster....
So at one point I thought "what the heck" I'll just reinstall it, since I try to run a clean ship with all drivers properly installed.

That was a very bad idea.
Other than pretty much EVERY software I ever used (30 years of professional computer experience, I'd say I know a bit about fixing bugs and problems), I just can't get it installed again.
Error 502 is what I get from the installer with absolutely no helpful hint on what that's supposed to mean.
Restarting, Uninstalling/Reinstalling, trying other versions, trying pretty much every hint I found on the web or here in the forums.
If I install the recommended NET update first, I get error message 4142.
Amazing...

The log tool drives it to the max: instead of allowing me to see if I can fix something on my own, it somehow encrypts the log to binary garbage...
WHY?

This is a frigging tool too set fan speeds/power schemes and - for me - to get rid of the silly colour stuff. I use the Laptop professionally for 3d graphics generation and don't need any blinking lights.

I have no idea why it should be so frigging hard to create a working installer that installs some tools on my harddrive.
On a laptop that is created by ASUS itself, so nothing mysterious is happening at all.
The hardware is 100% as I got it.

And NO, like others before me, I WILL NOT RESET MY LAPTOP.
It takes me about 2 - 4 weeks to get everything installed and set-up that I need for my work. I have absolutely no intention to do this just to find out if this silly tool will maybe run afterwards.

The latest version from the website gives me exactly the same useless Error 502 that every version other than that above linked, very old german version does. As does the update if I let it run.

So: I am all ears if there is any REAL solution to install this utility.
But ATM I assume from all I've read on the web that ASUS is unable and/or unwilling to fix the problem at the root, give the user meaningful feedback when the installer fails and come up with solutions instead of basically tell the user to go paint a wall.

Cheers,

Tom