cancel
Showing results for 
Search instead for 
Did you mean: 

Error code 502 with new Armoury Crate update!

DariusDavedane
Level 9
Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your uninstaller...no change.
Several reboots, switching off antivirus, runing everything in admin mode...no change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!
33,097 Views
49 REPLIES 49

As I see the german installer is for notebooks. I wouldn't try to install it to a dekstop and possibly make a bigger mess.
However, I am crawling the logs on my PC, and I found a strange part:

[2022. 08. 03. 9:54:10 15056] ACSetup: install progress Status: Installing Name: Armoury Crate Lite Service Progress: 0
[2022. 08. 03. 9:54:10 15056] ACSetup: ProcessRLSStreamPacket end
[2022. 08. 03. 9:54:11 15056] ACSetup: StartRLSReceiveInternal Receive data
[2022. 08. 03. 9:54:11 15056] ACSetup: ProcessRLSStreamPacket
[2022. 08. 03. 9:54:11 15056] ACSetup: install progress Status: Installing Name: Armoury Crate Lite Service Progress: 25
[2022. 08. 03. 9:54:11 15056] ACSetup: ProcessRLSStreamPacket end
[2022. 08. 03. 9:54:13 15056] ACSetup: StartRLSReceiveInternal rawBuffer == null
[2022. 08. 03. 9:54:13 15056] ACSetup: Disconnect before finish
[2022. 08. 03. 9:54:13 15056] ACSetup: ReturnResult2UWP command: Error result: Error
[2022. 08. 03. 9:54:13 15056] ACSetup: ReturnResult2UWP end
[2022. 08. 03. 9:54:13 15056] ACSetup: StartRLSReceiveInternal end
[2022. 08. 03. 9:54:24 15056] ACSetup: rawBuffer == null
[2022. 08. 03. 9:54:24 15056] ACSetup: StartReceiveInternal end

especially: ACSetup: ReturnResult2UWP command: Error result: Error.

I think the UWP here is the MS UWP, so the error is 99.99% sure is on the AC side.
Maybe some .NET components need for this, but instead of prompting it, just crashes?
Or ReturnResult2UWP could be a function in AC source code, which is buggy.

I am getting the 502 error when installing for the 1st time. I am on Rog Strix B550-F.
AC does start to install and after a couple of minutes it wants .net installed. So I select install .net and after a minute or so AC states that the program can not be installed. Then I used AC Uninstaller and rebooted. So I go to MS to get latest version of .net 4.8.4115.0 and installer tells me that I already have the latest version and it can not install.

Now what ?

918stanley wrote:
I am getting the 502 error when installing for the 1st time. I am on Rog Strix B550-F.
AC does start to install and after a couple of minutes it wants .net installed. So I select install .net and after a minute or so AC states that the program can not be installed. Then I used AC Uninstaller and rebooted. So I go to MS to get latest version of .net 4.8.4115.0 and installer tells me that I already have the latest version and it can not install.

Now what ?


I have the 502 Error too also the ROG STRIX B550-F GAMING Board and newest BIOS.
:mad:

Before it detects a "asus fan extension card 2" but I do not even have this "asus fan extension card 2" ......... Then the color changed to red by it's own ..... This Software is terrible. The Hardware is pretty good but the Software is a joke. Comon ASUS. ......

I'm sick of it. No way that they still not fixed this. This Software also does Automatic Updates. I do not want the damn Updates cause they are faulty, instable and untestet. Now I have to block the Software in Firewall to stop automatic Updates. Wow...

The old Offline "AC Full Package_1.0.3.62" (App-Version 5.0.11.0) does work for me and I have to block the Updates.
What a waste of time. This Software is clearly "anti consumer".

Ohhh and it has nothing to do with my OS by the way. I had the same trouble with fresh installed Windows 10 and now trouble with Windows 11.

Anyone got a Fix for this seems the Asus servers don't want to let people download the software hence the 502 error, and since Asus seems to refuse to make a full software package available. hopefully next software release they make sure it can be fully downloaded before requiring uninstall.

The full installation package has been out a while, did you guys try it?
94513

Direct Download:
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Full_Installation_Package.zip

Go to support page:
https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/

zapman2000 wrote:
Anyone got a Fix for this seems the Asus servers don't want to let people download the software hence the 502 error, and since Asus seems to refuse to make a full software package available. hopefully next software release they make sure it can be fully downloaded before requiring uninstall.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
The full installation package has been out a while, did you guys try it?
94513

Direct Download:
https://dlcdnets.asus.com/pub/ASUS/mb/14Utilities/Armoury_Crate_Full_Installation_Package.zip

Go to support page:
https://www.asus.com/supportonly/Armoury%20Crate/HelpDesk_Download/


Tried week ago when all this started...
Did not work for my ROG laptop.

The problem is stll here.
Forced update >> error 502 >> no options to break the cycle of suffering

anxs220 wrote:
Tried week ago when all this started...
Did not work for my ROG laptop.

The problem is stll here.
Forced update >> error 502 >> no options to break the cycle of suffering


Same here.

diegorluna wrote:
Same here.


Same here!

DryreL
Level 9
Hi all,

I have Zephyrus G14 (2021) RTX 3060 laptop on Windows 10 21H2. I was controlling my laptop fans via Armory Crate and it was fine. A couple days ago, an update arrived to Armory Crate. It requires to install Prerequisites Services. I clicked to "I understand" but it fails to install.

94503

I received Error code: 502.

94504

What I tried:

- Uninstall Armory Crate via "Armoury Crate Uninstall Tool V2.1.4.0"
- Try to install again via ArmouryCrateInstaller but receive some error.
- Uninstall again via "Armoury Crate Uninstall Tool V2.1.4.0"
- Try to install "AC Full Package_1.0.3.6", it works 1-2 days and suddently a new update pops up (you cannot ignore), and same thing happens.

It asks me to install Prerequisites Services, but it doesn't work. Armory Crate really awful program. I can't believe ASUS has such a terrible program. Pay the premium price, have the not-working program at all.

I'm looking for an idea to solve this problem. Thank you.

Nate152
Moderator