Showing results for 
Search instead for 
Did you mean: 

Error code 502 with new Armoury Crate update!

Level 9
Dear all and ASUS!

I am getting 502 error code when I forced to install your software. And I am not the only one, more and more people complaining about this error.

I tried everything, except Win reinstall, what I don't want to do.

I tried your change.
Several reboots, switching off antivirus, runing everything in admin change.
Every driver/software is up to date and legal on my computer.

Please, if anybody knows the solution, (or an alternative software to replace this), don't hesitate to provide the information.

Thank you for your help!

Hi DariusDavedane

Welcome to the ROG forum.

Try resetting the bios to default settings then try installing Armoury Crate.

Hi roger123,

Welcome to the ROG forum.

If on a laptop, try doing a system recovery then install Armoury Crate.

Dear Nate152!

Sorry, but it is fu*king not ok to do system recovery (or even reinstall), because some buggy update FORCED US to install for a garbage software.
I am a dev too, and if we would release this kind of sh*t for the public where approx. 8 people from 10 experiencing this serious issue the management would burn us in hell.

I know that its not your fault, but please, I kindly ask you, provide us some patch/hack/or even official older versions of the AC what can help us.

System recovery is not an answer, because 99.99% of the people know this "method" without any forum and questions...
And also, why do we need sys recovery? Older versions why worked?!

Furthermore, I read on another forum that even complete Windows reinstall not solved the bug.

PS.: PEOPLE! For RGB control use OpenRGB, I tried it, works great.

Since the only fix is to install an old AC version, doing a system recovery will not help.
Same for bios reset, lmao.

@DariusDaveDane -

I concur! Every AC update causes problems, sometimes minor and sometimes severe. Reloading Windows is NOT an appropriate "fix". I think it's the only "fix" Nate has to offer, so not blaming him, but it isn't acceptable for complex systems with lots of installed software and customizations.

As a retired IT manager, I can tell you I would have fired the team leader if something like this happened ONCE, and replaced the entire team if it happened AGAIN. But with AC, it just keeps happening, over and over and over and....

Sad, because on the RARE occasions when AC is fully working, I like it. But it is a ticking time bomb, and I live in fear of each subsequent update being the one that blows up my machine and costs me DAYS of reloading, software installing, and configuration again.
Z690-E, i9-12900k, 2x16 DDR5, 980pro nvme x3, Ryujin-II 360, Strix Animate-II, Evga 3090 ftw3

Sorry about that DariusDavedane, you didn't specify if you were using a laptop.

Here's what we can do:

I'll send you a private message with my email.

You generate a log in Armoury Crate and email it to me and I'll email your log to the ASUS team.

I'll send you a private message as well roger123.

What can also happen is after using the uninstall tool, some users will want to delete files and maybe even mess with the registry, this can cause problems with Armoury Crate.

Armoury Crate has come a long way and is still evolving, I think they're doing a good job with it. I personally am not having any issues with the latest version of Armoury Crate. I am using the ROG Strix Z690-F Gaming WiFi motherboard with seven other ROG devices, this problem looks to be laptop related.

Sorry I am not specified, but I don't have laptop, I have desktop, with Asus Tuf Gaming B460-PLUS.

I don't think this is laptop related. And yes I am frustrated a bit sorry, because I also liked AC. Kept my drivers up to date, RGB control etc.
Anyway I will send you the log.