cancel
Showing results for 
Search instead for 
Did you mean: 

Bad BIOS 313 for 2022 G14

Malaghan
Level 9
The latest BIOS 313 for the 2022 G14 laptops is seriously flawed and causes numerous issues. The most common is greatly increased battery drain when using the Optimized or Eco graphics modes. It's like 400% higher or more. The machine also does not properly switch the GPU's when plugged in and still has the dedicated GPU completely disabled until you restart. Others are reporting greatly reduced sound volume. Everybody having these issues confirms they are resolved only by rolling back the BIOS to version 312. Nobody has reported using 313 without issues.

ASUS needs to pull this "update" and give us a working BIOS ASAP.
5,988 Views
4 REPLIES 4

risola
Level 7
Malaghan wrote:
The latest BIOS 313 for the 2022 G14 laptops is seriously flawed and causes numerous issues. The most common is greatly increased battery drain when using the Optimized or Eco graphics modes. It's like 400% higher or more. The machine also does not properly switch the GPU's when plugged in and still has the dedicated GPU completely disabled until you restart. Others are reporting greatly reduced sound volume. Everybody having these issues confirms they are resolved only by rolling back the BIOS to version 312. Nobody has reported using 313 without issues.

ASUS needs to pull this "update" and give us a working BIOS ASAP.


You're not alone. Take a look at this reddit thread. It has suggestions that seem to make v313 BIOS behave much better.
https://www.reddit.com/r/ZephyrusG14/comments/wxjvd6/comment/ilruwkh/?utm_source=share&utm_medium=we...

Any updates on this? I am going to buy G14 GA402RK once they will be in stock (soon), I would like to have fixed power issues and maybe USB4 functional?

Malaghan
Level 9
The BIOS has been pulled by ASUS. Those issues are gone but USB4 is still yet to come.

Hello everyone, I've come across quite a few posts on reddit in which people complain that their laptop suddenly freezes and reboots without showing any errors or a blue screen. Only one error in Windows Kernel Power 41 log (63)

Model I am using: GA402RK R9 6900HS + RX 6800S + 32GB RAM

So I ran into this problem, it all started when I had version 11 of Windows installed. I tried different settings that I found on the Internet, but nothing helped.

At the same time, I will immediately say that the temperature of the processor and video chip has always been normal, no more than 80 degrees.

I switched to version 10 of windows and the problem did not appear for about 2-3 days and I was already delighted, thinking that the problem was in version 11, but it wasn’t there.

Next, I started experimenting again with AMD drivers, because I was sure that the problem lurked in this.

Initially, I always installed the newest version of the drivers from the site: https://www.amd.com/en/support/graphics/amd-radeon-rx-6000s-series/amd-radeon-rx-6000s-series/amd-ra...

The laptop works well, the frames in the game are stable, there are no freezes, but random reboots of the laptop pissed me off.

As a result, I tried to install drivers from the official ASUS website, which are recommended specifically for my laptop model. And here's what I noticed:

Frames in games decreased by ~20%, and heating in idle mode increased from 40-45 degrees Celsius to 55-60.

This is very annoying to me, because. On the drivers from the AMD website, the laptop was slightly warm and it was comfortable to use.

I would like to know if there are other people with a similar problem and if they observe heating on the OEM drivers from the ASUS site and the drivers from the AMD.com site?